PFsense mit Statischer IPV6 und Init7



  • Hallo zusammen

    Ich habe eine PFsene mit 4 Ethernet anschlüssen.
    Bisher hatte ich eine Dynamische IPV6 Adresse und habe nun bei Init7 mir eine Statische bestellt.
    Bis anhin hatte alles funktioniert mit IPV6. Seit ich aber auf Statisch umgestellt habe funktioniert das ganze nicht mehr.
    Ich habe von Init 7 ein Statisches 48 Netzbekommen 2a02:xxxx:xxxx::/48
    Nun habe ich aus diesem je Interface eine 64 Netz zugeteilt zb:
    Lan 2a02:xxxx:xxxx:0001:
    DMz 2a02:xxxx:xxxx:0002:

    Und da läuft dann jeweils ein DHCPServer der im bereich z.b. Lan
    2a02:xxxx:xxxx:1:ffff:ffff:ffff:0 - 2a02:xxxx:xxxx:1:ffff:ffff:ffff:ffff Adressen verteilt.

    Jetzt ist es so das ich aber nicht mehr auf das Internet komme via IPV6
    Im Dashboard zeigt es mir unter Wan :
    IPV4 : 251:xxx:xxx:xxx eine Adresse an
    IPV6: 2a02:168:2000:5:xxxx:xxxx:xxxx:xxx0 (warum bekomme ich da eine Adresse ich habe doch nur (siehe unten) Only request an IPv6 prefix, do not request an IPv6 address  angewählt)
    Und unter Gateways
    IPV4 251:xxx:xxx:xxx ein Gateway an
    IPV6 fe80::224:14ff:feef:72ff was meiner meinung nach ja eine LinkLocal Adresse ist.

    Unter dem Wan Interface habe ich
    IPv6 Configuration Type

    DHCP6 eingetragen

    DHCP6 client configuration
    Angewählt Only request an IPv6 prefix, do not request an IPv6 address
    48 eingetragen unter The value in this field is the delegated prefix length provided by the DHCPv6 server. Normally specified by the ISP.
    Sonst nichts angewählt.

    Als Info und anweisung habe ich von Init7 folgendes Mail bekommen:

    Sehr geehrter Herr Luegenbaron

    Ihr statisches IPv6 Prefix lautet wie folgt:

    2a02:xxx:xxxx::/48

    Bitte beachten Sie, dass Sie dieses über DHCPv6 Prefix Delegation
    beziehen müssen. Dem LAN-Interface Ihres Routers können Sie nun /64
    Netze aus diesem /48 Netz statisch zuweisen.

    Hat das jemand am laufen oder kann mir weiterhelfen was ich falsch mache?
    Ich hoffe ich habe alle relevanten angaben hinzu gefügt.

    Gruss Luegenbaron



  • So nun bin ich selber durch langes suchen und Probieren auf die Lösung gestossen.
    Ev. Hilft es ja jemandem weiter:

    Ich habe bei IPv6 Configuration Type: DHCP6
    Unter DHCP6 client configuration: Habe ich Advanced angekreuzt

    Dann unter Interface Statement: Send Options: ia-pd 0 eingetragen.
    Dann unter Identity Association Statement Prefix Delegation angewählt.

    Nun läuft es so bei mir und ich kann weiterbasteln

    Gruss Lügenbaron

    Und danke an alle die sich schon gedanken gemacht haben



  • Hallo,

    Ich bin ebenfalls bei init7 mit statischen IP addressen (ipv4 und ipv6).

    Das Problem was ich allerdings weiterhin habe ist, dass die incoming firewall rules für ipv6 immer eine der lokalen fe80:: … als "reply-to" mit dem physischen interface statt dem pppoe interface benutzt wird.

    Weiss jemand ob das überhaupt geht?

    ciao,
    Cybertoy



  • … mit Static IPV6 konfiguration des WAN Interfaces funktioniert es ...


Log in to reply