No IP on WAN using DHCP and Cable Modem [Supermicro]



  • New pfSense user. Took me a while to diagnose and thought I'd make it easier for anyone else in the future. I have a Supermicro X7SPA-HF and it has a shared IPMI interface on one of the NICs.

    SOLUTION: Swap em0/em1 interfaces since em0 shares the network with the IPMI - IPMI will always grab the first IP address from the cable modem and then no subsequent addresses will be issued. The other option is to disable IPMI.



  • Some main boards from SuperMicro comes pre-configured that the IPMI port will be acting as a fail over WAN
    port if the real WAN port is failing or going down. This can be often configured inside of the BIOS to IPMI only.
    Have you tried this out.



  • For safety reasons (IPMIs have awful security track records), I'd disable the NIC sharing where you have a dedicated IPMI port on the hardware. We do that on the systems we sell where that's applicable. If it's hardware that only has a shared port IPMI, use that port for your LAN rather than WAN as OP did.


Log in to reply