Problema: Squid Bloquea todos os sites http pfsense 2.2.6



  • olá boa tarde pessoa, sou novo no pfsense e gostaria de uma ajuda.
    instalei o squid e squidguard no pfsense 2.2.6 e ta bloqueando tudo os sites http. mesmo adicionando lista branco no squid e squidguard.

    já coloquei o squidguard para liberar tudo e o squid esta bloqueado todos os sites http. como faço pra deixar o squid liberando tudo e deixar o squidguard liberar somente a lista_branca que eu criei?



  • @dnascimento86:

    olá boa tarde pessoa, sou novo no pfsense e gostaria de uma ajuda.
    instalei o squid e squidguard no pfsense 2.2.6 e ta bloqueando tudo os sites http. mesmo adicionando lista branco no squid e squidguard.

    já coloquei o squidguard para liberar tudo e o squid esta bloqueado todos os sites http. como faço pra deixar o squid liberando tudo e deixar o squidguard liberar somente a lista_branca que eu criei?

    amigo,

    precisamos de mais detalhes. Se possível poste as configurações.

    Em relação ao informado, no squid vc adicionou o range de ip da rede em allow subnet? no squidguard já criou uma categoria no squidguard? baixou a shallalist?

    as informações estão muito vagas…

    veja se esse link te ajuda a configurar

    Youtube Video

    abraços

    Diego



  • onde consigo pegar as configurações pra poder postar aqui?

    no squid na aba general eu habilitei;
    Transparente proxy, enable logging e supress squid version .

    na aba acess control eu parametrizei apenas allowed subnets com a rede interna 192.168.0.0/24

    no squidguard está marcado como Enable e started.
    esta habilitado em general settings;
    Enable Gui Log, Enable log e Enable log rotation.

    não habilitei o blacklist pois não irei utilizar. (mas ja fiz com essa opção configurada, baixei a blacklist e aconteceu a mesma coisa)

    percebo que minha regra do squidguard funciona, mas o squid não deixa passar.
    percebo também que a opção habilitada no squid (supress squid version) não funciona. pois na tela de bloqueio esta apresentando a versão do squid

    no SquidGuard ainda na aba Target Categories eu criei a a categoria de sites_liberados contendo  apenas alguns sites para teste (uol.com.br, globo.com, terra.com.br)

    e na aba Common ACL

    a target rules list;
    Site_liberados [sites_liberados]  => access [allow] (já tentei tambem como whitlist)
    default access [all] => access [daney]

    e habilitado o log.

    Versão do Pfsense 2.2.6
    squid 4.3.10
    squidguard 1.9.18



  • @dnascimento86:

    percebo que minha regra do squidguard funciona, mas o squid não deixa passar.

    Revise suas configurações do squid, veja os logs e não publique a mesma pergunta/assunto em vários tópicos ao mesmo tempo.



  • @dnascimento86:

    onde consigo pegar as configurações pra poder postar aqui?

    no squid na aba general eu habilitei;
    Transparente proxy, enable logging e supress squid version .

    na aba acess control eu parametrizei apenas allowed subnets com a rede interna 192.168.0.0/24

    no squidguard está marcado como Enable e started.
    esta habilitado em general settings;
    Enable Gui Log, Enable log e Enable log rotation.

    não habilitei o blacklist pois não irei utilizar. (mas ja fiz com essa opção configurada, baixei a blacklist e aconteceu a mesma coisa)

    percebo que minha regra do squidguard funciona, mas o squid não deixa passar.
    percebo também que a opção habilitada no squid (supress squid version) não funciona. pois na tela de bloqueio esta apresentando a versão do squid

    no SquidGuard ainda na aba Target Categories eu criei a a categoria de sites_liberados contendo  apenas alguns sites para teste (uol.com.br, globo.com, terra.com.br)

    e na aba Common ACL

    a target rules list;
    Site_liberados [sites_liberados]  => access [allow] (já tentei tambem como whitlist)
    default access [all] => access [daney]

    e habilitado o log.

    Versão do Pfsense 2.2.6
    squid 4.3.10
    squidguard 1.9.18

    percebi q faltou:

    Squid.

    Aba general
    Marque, allow Users on Interface.
    Error language, preencha pt-br.

    Aba autentication
    Selecione o método de autenticação, se for local crie os usuários, se for ldap (usuários autenticados no active directory) procure no fórum como configurar o ldap no squid, existem diversos tópicos sobre esse assunto. :)

    No squidguard, na categoria que você criou, adicione os usuários.

    Acho q é isso!

    abraços,

    Diego


Log in to reply