Incorrect gateway



  • Hi,

    New install of 2.2.6 - I noted the following messages in System Logs (System > General):

    php-fpm[30014]: /interfaces.php: ROUTING: setting default route to 192.168.0.1
    php-fpm[30014]: /interfaces.php: The command '/sbin/route change -inet default '192.168.0.1'' returned exit code '1', the output was 'route: writing to routing socket: Network is unreachable route: writing to routing socket: Network is unreachable change net default: gateway 192.168.0.1 fib 0: Network is unreachable'
    

    In System > Routing I found this gateway defined:

    Name: GW_WAN (default)
    Interface: WAN
    Gateway: 192.168.0.1
    Monitor IP: 192.168.0.1
    Description: Interface wan Gateway

    Now - this is incorrect, but I know where it came from. Initially I had the pfSense box connected to a vDSL-modem/router, and was using that as the gateway (the IP was 192.168.0.1).

    I've now swapped the vDSL-modem/router for a modem only, and set the pfSense WAN interface to use DHCP - so the pfSense WAN interface now gets a public IP from my ISP.

    Any suggestions on how I set the correct gateway, and remove the old entry ??

    Thanks.



  • I would expect the Gateway (Status / System > Routing) to show the gateway IP received from the ISP (via DHCP).

    Wondering if I should attempt to remove the invalid gateway IP under "System > Routing" ?



  • Well … I got brave and deleted the incorrect gateway instance in System > Routing. It was automagically replaced with the correct ISP gateway.

    Status > Gateways looks good now also. Correct GW IP, and status is Online.

    No drama !


Log in to reply