[SOLVED] ipv6 assigning ips within the lan

  • I am new to ipv6. So far ipv6 is working on my WAN router and pfSense server. I have found many great how to's regarding tunneling. However, I am statically routed a /56 (and my uplink has a /126 assigned to my WAN router)

    However, I have not been able to talk to any system on the LAN with ipv6. I understand there is no NAT with ipv6, and there is a replacement NPt however I feel I should avoid NPt altogether.

    My LAN interface on pfSense is a local address fd00:f53b:82e4::2/64 however I feel this may be incorrect.

    I think my problem lies with giving the LAN a publicly accessible address and configuring Router Advertisements correctly, however, all attempts have gone without any success. I have not been able to find a good how to when the ipv6 is statically routed to the uplink.

    I have routed the ipv6 address on my WAN router to the pfSense server

    interface ve 10
     ip address 155.x.x.1
     ipv6 address 2607:x:x:8201::1/64
     ipv6 address 2607:x:x:8200::1/64
     ipv6 enable

    Network layout: Uplink <–> WAN router <--> pfSense <--> LAN switch <--> LAN Servers

    pfSense version: 2.2.6-RELEASE

    Any suggestion or input would be most appreciated. I will be happy to reply with any questions about my configuration. I'm sure that I am missing something simple.


  • Sucess :)

    In the event someone else comes across this here is what I did :)

    Assign an IPv6 address to your pfSense WAN. For me, I added an IP address to the virtual interface on my Router. Make sure you can ping an ipv6 address from the WAN interface using Diagnostics > Ping.

    interface ve 10
     ip address 155.x.x.1
     ipv6 address 2607:x:x:8200::1/64
     ipv6 enable

    Create a static route on your router to you pfSense WAN IP.

    ipv6 route 2607:x:x:8201::/64 2607:x:x:8200::2

    Assign the gateway IP to your pfSense LAN without a gateway. You should now be able to ping an ipv6 address from your LAN interface using Diagnostics > Ping.

    Setup DHCPv6 (if you are using it) and RA.

    Set any firewall rules that are needed for the outside world to communicate with your LAN side server

    You should be able to speak to the internet and back to your LAN side server :)

Log in to reply