Erro na Página de bloqueio do SquidGuard



  • Bom dia, tenho o Squid + SquidGuard configurados integrados com AD e bloqueando perfeitamente, porém quando acesso alguma página na qual existe bloqueio o Squid não libera acesso porém não exibe a página de bloqueio.
    Quando uso proxy transparente a página de bloqueio é exibida.
    ![Erro squid.JPG](/public/imported_attachments/1/Erro squid.JPG)
    ![Erro squid.JPG_thumb](/public/imported_attachments/1/Erro squid.JPG_thumb)



  • @jhonathan.ts:

    Bom dia, tenho o Squid + SquidGuard configurados integrados com AD e bloqueando perfeitamente, porém quando acesso alguma página na qual existe bloqueio o Squid não libera acesso porém não exibe a página de bloqueio.
    Quando uso proxy transparente a página de bloqueio é exibida.

    Amigo,

    Se entendi bem, a pagina de bloqueio não é exibida quando a pagina é "ssl" (https) correto?
    Isso é um assunto antigo, onde a sgerror.php não aparece em sites Https.

    infelizmente nunca consegui contornar esse problema :(.

    Quando pesquisei sobre isso no fórum (faz um tempo), o pessoal falava em subir uma nova instancia do lighthttpd mas nunca testei.

    Também não sei dizer se ativando a interceptação SSL no Squid resolveria esse problema, mas vale a tentativa.

    veja esses posts.

    https://forum.pfsense.org/index.php/topic,59624.msg330184.html#msg330184

    https://forum.pfsense.org/index.php?topic=68257.0

    Só tome cuidado com essas alterações pois podem inutilizar seu pfsense :)

    Espero ter ajudado.

    Abraços

    Diego



  • Bom dia Diego,
    Não havia testado desativar o SSL do PFSense, quando desabilitei SSL começou a exibir a página de erro, vou testar o procedimento que me passou este server ainda não está em produção, mais muito obrigado!!!!



  • @jhonathan.ts:

    Bom dia Diego,
    Não exibe a página de bloqueio em Sites HTTP também, porém quando ativo o proxy transparente a página de bloqueio é exibida para sites HTTP e HTTPS.
    Grato.

    Amigo,

    Veja a opção Redirect Mode nas configurações do Squidguard essa opção fica dentro do grupo em Groups Acl e dentro das categorias em Targets categories.

    Essa opção realiza um redirecionamento se ativa, pode ser esse o problema.

    Abraços,

    Diego


Log in to reply