137GB limit, cannot install to HD



  • First post, I want to thank those behind pfSense.  Even though it is not installed, it is running perfectly off my CDROM, and it is great.

    Some other threads showed people having a problem getting a large hard disk to work on systems that had a ~30GB limitation or so, but none of the suggestions seem to be working with me.

    I am using a system made circa 2000, which has a 137GB limitation in BIOS.  I am trying to get my ~250GB hard disk working with it, nad the BIOS detects it with 4128|255|255 CHS settings.  pfSense boots just fine, and the installer notices the values 128165|15|255 and suggests that I would not be able to boot, and suggests a modified 30515|255|63 CHS setting.  The installer exits with the error:

    /sbin/fdisk -v -f /tmp/new.fdisk ad0
    returned 1

    In the log I can see that it is not using the modified values.  I have tried this in both LBA mode and CHS mode in BIOS, same thing both times.  I have also tried to use the FreeBSD install disk, which properly recognizes and uses the 30515|255|63 setting, and can make and format a partition.  Restarting into pfSense, skipping past the installer, it still tries to format that detected partition, with the same error.  I have tried making a single partition < 137GB in the FreeBSD installer (I tried 120GB and 80GB), but neither of these get past the pfSense installer.  The FreeBSD installer notes that I must use the CHS values that my BIOS thinks it has, and I enter in 4128|255|255 manually, but the FreeBSD installer then rejects this, and tells me that they are most likely incorrect, and reverts to using the 30515|255|63.

    I have an 80GB drive that I can use, but I wanted to know if this was possible first.

    Appreciate all replies.

    -jst



  • I have a system with a similar BIOS limitation EXCEPT the BIOS doesn't even report a 160GB drive but does report a 80GB drive. Linux and FreeBSD both detect the 160GB drive and can use it, but since the BIOS refuses to recognise the 160GB drive I can't boot from it.

    I've had pfSense install and boot fine from the 80GB drive. I suggest you work with the 80GB drive.



  • I've just installed my ninth pfSense on a 60GB drive and it didn't boot from hard disk following the install.

    I got a "-", then a "", then it hung. I tried 1.2.1-RC2 from 14 November and a 1.2.1 from 7 July and both gave the same results.

    In the end I disabled LBA in the BIOS and set the root filesystem's size to 2GB. A 2GB swap partition followed, then the rest of the disk for /var.

    Boots like a charm now.


Log in to reply