Network setup with pfSense AP



  • First I would like to say hello to everyone here.  ;D
    I am venturing in new hardware/software territory and would appreciate some input, and please excuse my noobish questions.

    I have successfully installed pfSense on a new Alix 2C3 board. I have web access to the lan port but I have not yet run through the webconfigurator. Before I do go through it, I wanted to run my network diagram plan by you guys for your input. See the attached plan.

    I know some of you will advise me to let pfSense do the ppoe and put the modem in bridge mode, but it does not have a preset for bridge mode, and I am not sure how to do that. Instead I was thinking of turning off dhcp on the modem-router and NAT all to the pfsense wan port at 192.168.2.2
    Is this possible? ???

    Thank you for your input on my plan.

    Christian
    ![New network with IP.png](/public/imported_attachments/1/New network with IP.png)
    ![New network with IP.png_thumb](/public/imported_attachments/1/New network with IP.png_thumb)



  • You can do it that way, you just have to make sure that you clear the block private networks checkbox on your WAN interface.



  • Thanks for your input blak111.
    Everything is up and running  :) and we all have internet access!
    I have decided to work on the rest of the network before touching the modem part.
    I have set up my PF sense box with three interfaces: lan, wifi bridged to lan and Wan.

    I am running my wireless clients in dhcp and both Lan and wifi are on the same subnet of course.
    I cannot seem to understand why I can ping all clients from the pfsense web access, but the clients cannot ping each other. This does not seem right to me, especially in the context of the bridge to lan and single dhcp server.

    Otherwise it is all working fine, everyone has internet access and all. But my machines cannot see NAS and my wifi music system (squeezebox duet) cannot communicate with each other or with music server… :(

    Any ideas are welcome. I tried ticking

    Bypass firewall rules for traffic on the same interface

    in the advanced menu, but this did not do the trick. I attached my 3 rules for your review.

    ![Picture 4.png](/public/imported_attachments/1/Picture 4.png)
    ![Picture 4.png_thumb](/public/imported_attachments/1/Picture 4.png_thumb)



  • It's been a while since I've looked at an interface page for wireless, but I believe there was an option there for allowing clients to communicate with each other directly. Do you have that set?


Log in to reply