Old ATH driver?



  • Hello

    Since update to 2.3-RC i get a lot of the following error-messages during heavy WiFi use:

    ath0: ath_tx_default_comp: bf 0xfffffe0000980cd8: seqno 2693: bf_next not NULL!

    During my researches on the internet I found out, that this "error" was solved with a small "hack" in if_ath_tx.c a long time back.

    I found also a bugreport on redmine (#5453) which was closed a month ago with a reversion of a lot of files for the ath-driver.

    If I compare the files RELENG_2_2 with 2.3-RC, I think, the files in RELENG_2_2 are newer than the files in devel 2.3-RC.

    WiFi was IMHO usable in 2.2.6 for my home-environment, but now on 2.3-RC I experience a lot of interruptions during heavy use (downloading big files, watching movies on youtube, you name it…). After disconnect and connect everything works for the next few minutes.

    I think, this is due to the wrong (old?) files which where reversed in above mentioned bugreport.

    If you need more informations on this, I'm glad to help!

    Thanks for taking a look at this.

    Best regards

    HW: APU1C4, wle200nx (Atheros AR9280 chipset).



  • I'm also seeing it during file copy but not while web browsing. Definitely a regression.


  • Rebel Alliance Developer Netgate

    We had ath from 11-CURRENT on 2.3 for a while but it would panic as soon as a client would associate, so we had to back it down to the same code from 10-STABLE.



  • Thanks for your answer.

    I read the bugreport on redmine, and it is clear, that 11-CURRENT is not working properly. But is it then possible to use the same code as in 2.2.6? This worked reasonably, now with the 10-CURRENT it seems very unstable.


  • Rebel Alliance Developer Netgate

    2.3 has the stock code from 10.3-RELEASE. IIRC, the code on 2.2.6 was from 11-CURRENT back in Feb 2015, so it's quite old as well.

    At this point in the release cycle, it's unlikely to change. I've got wireless going in a couple test units and it has been fairly stable for me, though I have only tried it on 2 different ath cards.



  • Ok, thanks again for answering. Will test it myself further and report back, if I see any error message.

    During normal use it's no problem, I only encountered problems during heavy use like big file download.



  • Makes sense to stick to 10-STABLE. Time to get a UniFi AC Lite AP anyway.



  • Hello,

    I ve the same issue ( ath0: stuck beacon; resetting (bmiss count 4)  )

    Is there another Wifi hardware out there that works fine with the PC Engines AMD APU1D4?


Log in to reply