DHCP leases don't get registered in DNS as expected



  • I noticed that DHCP leases get registered with the DNS in a different way than what I configure in the Web GUI.

    It seems like the Dynamic DNS domain (clients.mynet.zz) I specified on the DHCP server configuration page does not get respected. Instead, all DHCP clients' names get registered in the domain specified on the General Setup (mynet.zz) page.

    Also, disabling the "Enable registration of DHCP client names in DNS" checkbox on the DHCP server configuration page does nothing. Apparently, the only way to disable the Dynamic DNS registration is to uncheck "Register DHCP leases in DNS forwarder" on the DNS forwarder configuration page.

    However, I would like to only have the Dynamic DNS registration on one DHCP interface, not all of them. This is not currently possible, despite the Web GUI (theoretically) offering this possibility.



  • logon via putty and shell ( option 8 )
    check the command line of dnsmasq has a -l option. (ps ax)

    18961  ??  S      0:00.03 /usr/local/sbin/dnsmasq -l /var/dhcpd/var/db/dhcpd.leases -s local

    usefull tip:
    I've created a "dnsmasq.conf" in /usr/local/etc/

    # increase DNS cache size (max is 10000)
    cache-size=10000
    #
    # Give local DHCPleases names. 
    # (why not via dnsmasq.conf? pfsense uses command line -l?)
    #dhcp-leasefile= /var/dhcpd/var/db/dhcpd.leases
    # (this could be used, but it's commented out)
    #
    # Extra : Blackhole DNS adresses.
    conf-file=/usr/local/etc/blackhole.conf
    #
    

    dnsmasq.conf gets loaded automatically when dsnmasq is started and no "-c" option is given.
    (in linux it's loaded from /etc/)
    Blackhole.conf is a blackhole dns file. (converted via perlscript to correct format)



  • I don't think your suggestion applies to my case. If it does, please elaborate on how a blackhole DNS would help

    dnsmasq is running with the -l option.

    Regards,
    mkuron



  • http://forum.pfsense.org/index.php/topic,11159.0.html

    Basically it uses dnsmasq as a dns query cache (10.000 addresses), before it will ask the ISP or OpenDNS dnsservers.

    Moving the dsnmasq "bootup" before the timesync works, only problem is updating new images/tgz updates.
    Before mayor updates remove the "/etc/rc" and "/etc/rc.bootup" modifications.


Log in to reply