FIXED: IPSec broken with July 11 version



  • I did the "auto upgrade" to Alpha Friday.  I had no internet connectivity, and the following errors:

    php: : There were error(s) loading the rules: /tmp/rules.debug:232: syntax error /tmp/rules.debug:233: syntax error /tmp/rules.debug:234: syntax error /tmp/rules.debug:235: syntax error /tmp/rules.debug:236: syntax error /tmp/rules.debug:237: syntax error /tmp/rules.debug:238: syntax error /tmp/rules.debug:239: syntax error /tmp/rules.debug:240: syntax error /tmp/rules.debug:241: syntax error /tmp/rules.debug:242: syntax error /tmp/rules.debug:243: syntax error pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [232]: pass out on $wan route-to ( em1 ) proto udp from any to xXX.XXX.XXX.154 port = 500 keep state label "IPsec: Work - outbound isakmp"

    I have hidden the ip address (xxx.xxx.xxx.154)

    The previous alpha worked fine.

    I have two ipsec tunnels, and I had to disable both to get filters to load - which means ipsec is completely broken for me now.



  • With today's build (built on Sat Jul 12 18:55:40 EDT 2008) I no longer get rule errors with ipsec, but now raccoon won't start.  On the services page, I get the following:

    Warning: file_get_contents(/var/run/openvpn_server0.pid): failed to open stream: No such file or directory in /etc/inc/service-utils.inc on line 146 Warning: file_get_contents(/var/run/openvpn_client0.pid): failed to open stream: No such file or directory in /etc/inc/service-utils.inc on line 146

    Attempting to start raccoon fails (though pfsense says it started successfully, it does not)




  • I didn't even think to look on the system logs page under ipSec, but here's the error that I would assume is causing racoon to not start?

    Jul 12 19:32:19 racoon: ERROR: parse error is nothing, but yyerrorcount is 2.
    Jul 12 19:32:19 racoon: ERROR: /var/etc/racoon.conf:20: "on" NAT-T support not compiled in.
    Jul 12 19:32:19 racoon: ERROR: /var/etc/racoon.conf:9: "4500" NAT-T support not compiled in.
    Jul 12 19:32:19 racoon: INFO: Reading configuration from "/var/etc/racoon.conf"



  • Now working with  "Sun Jul 13 16:41:08 EDT 2008" build


Log in to reply