Strange DNS problem…



  • Hi.
    I have a simple setup like this:
    Router –-- LAN for most of the house ---- my pfsense box ---- my two computers

    The thing is that after a period of time (from 5 seconds to 10min normally, but up to several hours some times) no domain names are being resolved. If I constantly keep browsing one specific page I can stay there pretty long, but if I try to access another one it doesn't find it. But I do not get disconnected from MSN.
    This problem is "reset" every time I release and renew the WAN IP of my pfsense box and the IP of my computers or when I restart dnsmasq.

    I then tried to install TinyDNS to see if that helped, it kinda did... The strange thing I described above stops, but it takes long to resolve the domain names the first time (like 5-30 seconds) and if I'm not browsing that page for some time the long delay comes back, this is very annoying. (Another problem that occured was that the overrides I had in the DNS forwarder no longer works, but I kinda expected that)
    I have checked and unchecked the "Allow DNS server list to be overridden by DHCP/PPP on WAN" with no effect on any of the problems.

    If there is anything about my setup you want more details on, just ask and I will do my best to explain.



  • I would boot from the livcd and keep it as default as possible to confirm it's not a hardware thing and change lan ip to something like 10.0.x.x/24 if your router uses 192.168.x.x/24



  • I tried what you said. Booted up from the livecd and only changed the IP, exactly same thing happens… But can it be a hardware problem? Doesn't really look like that way (But what do I know..?)



  • Could it be a MTU problem? http://forum.pfsense.org/index.php/topic,9301.msg52658.html#msg52658
    else recheck network settings on lan clients



  • As for the MTU, i did a ping -f -l 1472 www.dslreports.com as the link in the post you linked to explained without getting a message telling med the packet needs to be fragmented.
    What should I check on the lan clients? Both the laptop and desktop has been used in several different networks and I havn't had any problems earlier. (They both run Win Vista btw)



  • What should I check on the lan clients?

    If it had a wrong gateway or dns servers.
    If the vista clients are set with opendns dns servers does it then work?
    208.67.222.222
    208.67.220.220

    Else i only know of this post http://forum.pfsense.org/index.php/topic,3528.0.html



  • The gateway and dns at the clients were set to my pfsense boxs IP (10.0.0.1) as they should. Now when I tried disabled dnsforwarder and set the opendns IPs as dns servers it seems to work, gonna give it some more time before i yell hoooray though. But I will not be able to override names now?

    Thanks for your help btw, really appreciate it  :)



  • Go to System/General Setup/ DNS Servers…

    What do you have there?



  • I wrote in the 2 IPs to OpenDNS that Perry gave me. And it seems to be working  ;D


Log in to reply