Unable to start pfSense login screen



  • Hi all,

    VirtualBox
    Host - Ubuntu 14.04 desktop

    I followed;
    How to install pfsense in Virtualbox
    http://rumyittips.com/how-to-install-pfsense-in-virtualbox/

    to install pfSense on a VM

    After installation finished I couldn't start pfSense login screen

    On terminal it popup following options

    –-----
    ......
    ......

    FreeBSD/amd64 (pfSense.localdomain) (ttyv0)

    *** Welcome to pfSense 2.2.6-RELEASE-pfSense (amd64) on pfSense ***

    WAN(wan) ->em0 ->v4/DHCP4: 192.168.8.2/24
    LAN(lan) ->em1  ->v4: 192.168.1.1/24
    0)Logout(SSH only)  9)pfTop
    1)Assign Interfaces  10)Filter Logs
    2)Set interfaces(s) IP address  11)Restart webConfigurator
    3)Reset webConfigurator password  12)pfSemse Developer Shell
    4)Reset to factory default  13)Upgrade from console
    5)Reboot system 14)Enable Secure Shell (sshd)
    6)Halt system  15)Restore recent configuration
    7)Ping host  16)Restart PHP-FPM
    8)Shell

    Enter an option:

    Pls refers to attached screenshot

    Please advise which option shall I select?  Thanks

    Regards
    satimis



  • This is the standard console you will see once you've finished installation. What you choose to do at this point is up to you. If you want to view the web management gui, point your browser to your LAN address (192.168.1.1) and log in with your admin credentials. If you haven't changed the default details, the login is 'admin' with password 'pfsense'.



  • @muswellhillbilly:

    This is the standard console you will see once you've finished installation. What you choose to do at this point is up to you. If you want to view the web management gui, point your browser to your LAN address (192.168.1.1) and log in with your admin credentials. If you haven't changed the default details, the login is 'admin' with password 'pfsense'.

    Thanks for your advice.

    I haven't done any configuration yet.

    However I could neither connect it on Host browser running http://192.168.1.1 nor ping 192.168.1.1 on Host terminal

    Edit:
    Connection
    FTTH (500mbps) -> ONT (4 ports) -> 2 PCs-Virtual Machine
    (Dynamic IP)

    ONT-Huawei HG8045

    Oracle VirtualBox
    Host Ubuntu 14.04 desktop
    VMs Ubuntu 14.04 desktop/Ubuntu 14.04 server/Windows 10 etc.
    (PC-4/8 cores, RAM-8/32G, HDD-SSD 1TB, about 20 VMs running on each Virtual Machine)

    ONT assigned IP – 192.168.8.2/3/4/5 etc.

    satimis


  • Netgate

    Then you have something wrong in your virtual environment, switching, etc.



  • @Derelict:

    Then you have something wrong in your virtual environment, switching, etc.

    But pfSense can ping Host 192.168.8.3


  • Netgate

    @satimis:

    @Derelict:

    Then you have something wrong in your virtual environment, switching, etc.

    But pfSense can ping Host 192.168.8.3

    Different NIC.

    What is the IP address of the workstation you are testing from?

    Can pfSense ping that?



  • @Derelict:

    Different NIC.

    What is the IP address of the workstation you are testing from?

    Host

    eth0     
    inet addr:192.168.8.3

    Can pfSense ping that?

    Yes, pfSense can ping Host IP and public IP.

    This PC (say PC-1), running Oracle VirtualBox, has been working for sometimes without problem.

    Previous network connection;
    ISP -> FTTC (static IP, 100mbps) -> Router -> PC -> VMs

    Host
    /etc/network/interfaces```

    auto lo
    iface lo inet loopback

    The primary network interface

    interfaces(5) file used by ifup(8) and ifdown(8)

    auto eth0
    iface eth0 inet manual

    add bridge ports

    auto br0
    iface br0 inet static
            address        192.168.0.200
            dns-nameservers xxx.xxx.xxx.xxx (ISP dns)
            network        192.168.0.0
            netmask        255.255.255.0
            broadcast      192.168.0.255
            gateway        192.168.0.1
            bridge_ports    eth0
            bridge_fd      9
            bridge_hello    2
            bridge_maxage  12
            bridge_stop    off

    
    New network connection;
    ISP -> FTTH (dynamic IP, 500mbps) -> ONT -> PC -> VMs
    
    Host
    /etc/network/interfaces```
    
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto eth0
    iface eth0 inet dhcp
    
    

    After installing pfSense I couldn't start VMs with following warning popup:

    
    Could not start the machine ub1404dkPC1A01 because the following physical network interfaces were not found:
    br0 (adapter 1)
    You can either change the machine's network settings or stop the machine.
    
    
    
    Result Code: 
    NS_ERROR_FAILURE (0x80004005)
    Component: 
    SessionMachine
    Interface: 
    ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}
    
    

    Even having changed Network
    from:  Bridged Apdater
    to: NAT

    I have another PC (say PC-2) with similar config on this network
    ISP -> FTTH (dynamic IP, 500mbps) -> ONT -> PC -> VMs

    All VMs are working after changing from:"Bridged Apdater" to: "NAT" on Network, able to connect Internet.

    Did I make mistake on installation?

    I can create another pfSense VM and mark it "pfSense-1" to test.  Then there will be 2 pfSenses on this PC?  Can it work?  OR I have to delete the current pfSense?

    Regards
    satimis



  • For my virtual box I set the first adapter as NAT, and a second as Host. Relised that the default gate on the Host virtual adapter is 192.168.56.1 (in my case since its the default VirtualBox setup) if you set the LAN interface ip in the pfSense console to anthing other than ending with a one; it'll work when you have it like this. You could also go into virtualbox network adapter settings to edit the default.
    At times I do have to do a mix of options 11/16 or even both. I don't remember if I fix this as it only happens on my Mac and not on the same VM copy I have on my Windows Machine.








  • @crisdavid:

    For my virtual box I set the first adapter as NAT, and a second as Host.

    Did you refer to pfSense network?

    I can't set "Host-only Adapter"
    Invalid settings detected



  • Go into the virtualbox preferences, network tab, and create a host network adapter (green adapter looking icon on the right corner of the window with a plus sign on it). Go back to your virtual machine settings, add the second adapter (as a host adapter), then insure that it doesn't give the invalid settings. It should automatically choose the newly created adapter(vboxnet0). Lastly if you leave the defaults that you need to set the lan interface as 192.168.56.2, you can also say no to setting up DHCP. GUI should come right up.




  • @crisdavid:

    Go into the virtualbox preferences, network tab, and create a host network adapter (green adapter looking icon on the right corner of the window with a plus sign on it). Go back to your virtual machine settings, add the second adapter (as a host adapter), then insure that it doesn't give the invalid settings. It should automatically choose the newly created adapter(vboxnet0). Lastly if you leave the defaults that you need to set the lan interface as 192.168.56.2, you can also say no to setting up DHCP. GUI should come right up.

    Hi crisdavid,

    Thanks for your advice which works here.

    Performed following steps:-

    -> Preference -> Network -> Host-only Networks
    Adds new-host-network
    vboxnet0

    and

    Set "Adapter 2" of pfSense and all VMs as follows;
    Attached to:[Host-only Adapter]
    Name:[vboxnet0]

    Now on VM's browser;
    http://192.168.1.1

    popup pfSense login page
    User - admin
    Pass - pfsense

    starts "Status: Dashboard"

    But it doesn't work Host.  I can't figure out a solution.

    Regards
    satimis



  • Can you provide a screenshot? Haven't hit this bump you have, even when virtualising it within a Ubuntu VM



  • @crisdavid:

    Can you provide a screenshot? Haven't hit this bump you have, even when virtualising it within a Ubuntu VM

    Please refers to attached photos

    satimis








  • Is your first adapter still a bridge adapter? or is it NAT adapter?

    If you go to the update tab from the GUI and go into the update page. Try to just save the page again (attachments below); I understand this is 2.3 but I can't remember if this was still there on 2.2.6
    I encountered this when on the beta of 2.3 (before the release) might help you the same.

    P.S. I'm virtualizing a ubuntu machine and running another virtual box instance of pfsense to help with your problem since I don't have a spare PC. I'm just currently in class and just spun up my pfSense Testing VM on my mac to provide the visuals :P






  • @crisdavid:

    Is your first adapter still a bridge adapter? or is it NAT adapter?

    If you go to the update tab from the GUI and go into the update page. Try to just save the page again (attachments below); I understand this is 2.3 but I can't remember if this was still there on 2.2.6
    I encountered this when on the beta of 2.3 (before the release) might help you the same.

    P.S. I'm virtualizing a ubuntu machine and running another virtual box instance of pfsense to help with your problem since I don't have a spare PC. I'm just currently in class and just spun up my pfSense Testing VM on my mac to provide the visuals :P

    Thanks for your advice.

    My Status Dashboard looks different to yours.  I couldn't find Update and Update Settings under System

    My pfSense was installed on;
    pfSense-LiveCD-2.2.6-RELEASE-amd64-20151221-1450.iso

    My first adapter is still a bridge adapter
    Name: eth0

    satimis



  • You can try to use a NAT adapter instead.
    I also noticed you're on UTC time (Not sure if that makes a big deal) but could help to set pfSense to use local time. Unfortunately i'm trying to figure out where and how I was able to switch the time to use that :/.



  • @crisdavid:

    You can try to use a NAT adapter instead.
    I also noticed you're on UTC time (Not sure if that makes a big deal) but could help to set pfSense to use local time. Unfortunately i'm trying to figure out where and how I was able to switch the time to use that :/.

    Set both pfSense and VMs
    1st adapter - NAT
    2nd adapter - Host-only Adapter
    Name: vboxnet0

    It is the same, nothing changed.

    Host still can't ping pfSense 192.168.1.1 but pfSense can ping Host 192.168.8.3

    Actually pfSense is working.  I'm now searching document to configure it as a physical router assigning IP to VMs to allow them to be browsed on Internet



  • Old thread, but I just figured out the answer for myself

    I could install and setup pfSense just fine, it got a DHCP IP on the WAN and 192.168.1.1 on the LAN, but I couldn't ping the box, or hit https://192.168.1.1 in a browser!

    The key is to configure VirtualBox's host-only networks; not just the network adaptors for the VM, but VBox's configuration for the networks themselves

    Go to: VirtualBox -> Preferences -> Network -> Host-only networks

    For me vboxnet0 (the one you get by default is configured as)

    192.168.0.1
    255.255.255.0
    DHCP Enabled
    

    I'm pretty sure this means that if you setup the LAN interface on the VM to be a "Host-only Adapter", your host machine gets assigned an IP address of 192.168.0.1 on the virtual network that VBox sets up for you. This means you're on a separate subnet than the LAN interface of pfSense

    TL;DR The Fix:

    Configure host-only network "vboxnet1" (or any of the other host-only networks if you're already using vboxnet1 for other VMs) with the following:

    192.168.1.77 (or whatever IP you want your host to appear as on the network)
    255.255.255.0
    DHCP Disabled
    

    The make sure that the LAN adapter on your pfSense VM is a "Host-only Adapter" and that it's using "vboxnet1" (or whatever network you configured above)

    Reboot/re-install and http://192.168.1.1 should work now

    VBox   : 5.1.16
    pfSense: 2.3.3
    MacOS X: 10.12.2