Squid3 rodando mas para de funcionar após alguns minutos



  • olá, boa noite a todos !

    fiz uma instalação limpa da versão 2.2.6-RELEASE (amd64) built on Mon Dec 21 14:50:08 CST 2015 FreeBSD 10.1-RELEASE-p25

    segui o tutorial do joão batista da rocha neto Configurando Squid3 + SquidGuard3 + Proxy Transparente bloqueando SSL/HTTPS no PFSense https://www.youtube.com/watch?v=neXcYtFDRLA&nohtml5=False

    os pacotes não instalaram logo de cara, deram alguns erros mas pelo que pesquisei na internet a orientação era para tentar mais de uma vez que os pacotes seriam instalado e realmente foi isso que aconteceu.

    segui o tutorial a risca e todos os bloqueios https e http funcionaram perfeitamente, mas depois de uns 20 minutos o squid para de funcionar e a navegação fica toda liberada.

    logo de cara pensei que poderia ser algum problema do squidguard, removi o pacote e o problema não foi resolvido, resolvi reinstalar todo o pfsense e desta vez so instalei o squid3 para testar mas depois de uns 20 minutos o squid para de funcionar tambem.

    ja dei um tail no access.log e verifiquei que o arquivo nao está sendo registrando nada mesmo com meu pc navegando na internet

    acessei o http://www.lagado.com/proxy-test e o resultado é This request appears NOT to have come via a proxy.

    alguem sabe o que pode ser ?



  • descobri o que está fazendo o squid parar.

    o squid para quando coloco os endereços dos bancos no Bypass Proxy for These Destination IPs o squid

    tenho a seguinte lista:

    banklineplus.itau.com.br;itau.com.br;bankline.itau.com.br;itau.mobi;itaubba.com.br;itaupersonnalite.com.br;itauprivatebank.com.br;itauuniclass.com.br;bradesco.com.br;bradesconetempresa.b.br;banco.bradesco;bradescopessoajuridica.com.br;

    fiz um teste inserindo um a um e descobri que quando insiro o itauuniclass.com.br o squid para

    porque será que ao incluir esse endereço o squid para ?



  • boa tarde !

    tive mais um problema preenchendo os endereços no  Bypass Proxy for These Destination IPs
    conforme eu coloco mais endereços no campo o squid para de funcionar, alguem mais passou por isso ?

    eu preciso preencher ali alguns sites de serviços para que não passem pelo proxy mas a quantidade que eu posso preencher é limitada.

    pesquisei bastante para ver se achava alguem relatando esse erro mas não encontrei ninguem descrevendo isso.

    será que estou fazendo algo errado ?

    meu cenario atual é:

    pfsense 2.2.6-RELEASE (amd64)
    squid3 0.4.7
    squidGuard 1.9.18
    sarg 0.6.10
    cron 0.3.4

    obs: esse problema eu já tinha só com o pacote squid3 instalado



  • Ola!
    Já passei por esse problema!!
    Verifique no Status > System Logs > Verifique na Aba (system > General). E veja os log's deve ter algo relacionado a algum "link/Dominio" que voce incluiu no ByPass e nao esta conseguindo resolver o nome pelo DNS.



  • derikdk muito obrigado pela dica,

    vou preencher novamente com os dominios que preciso que passem direto e vou analisar o log.

    assim que conseguir fazer respondo aqui

    mais uma vez muito obrigado !



  • derikdk só hoje consegui fazer os testes, realmente tinha a ver com o que você falou.

    o log retorna o seguinte erro:

    php-fpm[86695]: /rc.filter_configure_sync: The command '/sbin/pfctl -nf /tmp/rules.test.packages' returned exit code '1', the output was 'no IP address found for itauuniclass.com.br /tmp/rules.test.packages:26: could not parse host specification'

    php-fpm[86695]: /rc.filter_configure_sync: There was an error while parsing the package filter rules for /usr/local/pkg/squid.inc.

    php-fpm[5500]: /status_services.php: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was ''

    e a partir dai o squi tem o status de rodando mas nao filtra mais nada

    eu consigo acessar o itauuniclass.com.br normalmente na minha rede, inclusive ele redireciona para itau.com.br

    acho que vai dar pra funcionar tudo aqui sem essa liberação.

    agradeço pela sua dica.

    abraço


Log in to reply