Dpinger won't start



  • After upgrade from 2.2.6 to 2.3 dpinger won't start.

    
    Apr 12 14:36:49  php-fpm  9647  /status_services.php: The command '/usr/local/bin/dpinger -S -r 0 -i WAN_DHCP -B 50.x.x.148 -p /var/run/dpinger_WAN_DHCP_50.x.x.148_50.x.x.1.pid -u /var/run/dpinger_WAN_DHCP_50.x.x.148_50.x.x.1.sock -C "/etc/rc.gateway_alarm" -d 0 -s 15000 -l 35000 -t 60000 -A 1000 -D 500 -L 20 50.x.x.1 >/dev/null' returned exit code '1', the output was ''  
    Apr 12 14:36:49  php-fpm  9647  /status_services.php: Error starting gateway monitor for WAN_DHCP  
    
    
    • IP addresses sanitized with x.x

    2.3-RELEASE (i386)
    built on Mon Apr 11 18:12:06 CDT 2016
    FreeBSD 10.3-RELEASE



  • If you edit and save the gateway, or run that same command manually (minus the /dev/null part), does it work?



  • Yup got it.  The 2.2.6 settings were incompatible with some of the 2.3 defaults.

    Thanks,



  • Which settings in particular? We ought to be unsetting anything like that in config upgrade if there is something that's going to break things post-upgrade.



  • I believe it's an error moving from early beta to release.

    The parameters "-s 15000 -l 35000 -t 60000 -A 1000" are an invalid combination and will produce an error in the UI:

    The following input errors were detected:

    * The time period needs to be greater than twice the probe interval plus the loss interval.
        * The alert interval needs to be greater than or equal to the probe interval.



  • The 2.2.6 settings were:

    
    		 <gateway_item><interface>wan</interface>
    			<gateway>dynamic</gateway>
    			<name>WAN_DHCP</name>
    			<weight>1</weight>
    			<ipprotocol>inet</ipprotocol>
    			<interval>15</interval>
    			<avg_delay_samples>4</avg_delay_samples>
    			<avg_loss_samples>4</avg_loss_samples>
    			<avg_loss_delay_samples>1</avg_loss_delay_samples>
    
    			 <defaultgw><down>35</down></defaultgw></gateway_item> 
    
    

    2.3 came up with
    Probe Interval: 15000
    Loss Interval 35000
    Time Period: 60000
    Alert interval: 1000

    Resulting in:
    The following input errors were detected:
    •The time period needs to be greater than twice the probe interval plus the loss interval.
    •The alert interval needs to be greater than or equal to the probe interval.



  • @dennypage:

    I believe it's an error moving from early beta to release.

    This was a 2.2.6 production installation that had never been touched by 2.3 alpha, beta, nor RC.



  • My bad.

    @NOYB:

    This was a 2.2.6 production installation that had never been touched by 2.3 alpha, beta, nor RC.



  • Looking at the code, it may be better to just unset the 'interval' and 'down' parameters rather than trying to convert them.

    @cmb:

    Which settings in particular? We ought to be unsetting anything like that in config upgrade if there is something that's going to break things post-upgrade.



  • @dennypage:

    Looking at the code, it may be better to just unset the 'interval' and 'down' parameters rather than trying to convert them.

    I merged this change from Phil Davis which seems like it should address that for those who first upgrade to 2.3.1.
    https://github.com/pfsense/pfsense/pull/2869/commits/21300959d92cd0a2cbd8a756ee5ecf25f6193e09

    I'm not necessarily opposed to unsetting those two parameters though, you still think that's a good idea?



  • Given that Phil has already written the code I don't see a reason not to use it.


Log in to reply