Upgrade Took Me From 2.2.3-RELEASE (x86_64) to 2.3-RELEASE (i386)



  • For some reason that I cannot ascertain, when I did the upgrade pfSense 2.2.3-RELEASE (x86_64) using the GUI, it installed 2.3-RELEASE (i386).

    This isn't the first time this has happened (the same occurred going from 2.2.2-RELEASE to 2.2.3-RELEASE), but I cannot determine the cause.

    As a result, I'll need to wipe the file system, and start over by manually installing 2.3-RELEASE (x86_64) with a restored backup of my prior config and RRD data from 2.2.3, but I'm trying to ascertain if anyone knows what might be causing this to occur.

    Edit: Successfully finished reformatting, installing 2.3-RELEASE (amd64), and restoring the config. Things are (seemingly) smooth now, though I have no idea why this occurred in the first place.



  • That's what happens when you have the wrong URL hard coded under System>Firmware, Updater Settings tab.

    Now in 2.3 and newer, it's impossible to switch architectures, since it's no longer doing the monolithic updates of old.

    Before upgrading any 2.2.x or earlier system, it's a good idea to double check System>Firmware, Updater Settings, and make sure you have "Use an unofficial server for firmware upgrades" unchecked. Then you'll stay with whichever architecture you have installed.

    With the old style of updates you could (with some caveats) switch back with another upgrade to the other architecture, but that's not possible once you're up to 2.3. Backup your config, reinstall 64 bit, restore.



  • @cmb:

    That's what happens when you have the wrong URL hard coded under System>Firmware, Updater Settings tab.

    Now in 2.3 and newer, it's impossible to switch architectures, since it's no longer doing the monolithic updates of old.

    That explains it. I hadn't noticed that the URL was incorrect.

    @cmb:

    Before upgrading any 2.2.x or earlier system, it's a good idea to double check System>Firmware, Updater Settings, and make sure you have "Use an unofficial server for firmware upgrades" unchecked. Then you'll stay with whichever architecture you have installed.

    With the old style of updates you could (with some caveats) switch back with another upgrade to the other architecture, but that's not possible once you're up to 2.3. Backup your config, reinstall 64 bit, restore.

    I did notice that the option to manually supply the "firmware" is gone now. I surmised that this had to do with the move to the package methodology.

    I made a config backup before performing the upgrade, and was able to use that to successfully restore the config and RRD data post reinstall to 64-bit.

    Thanks for your answer. I appreciate it.