[Resolvido] Squid parado, não reinstala nem desinstala após atualizar para 2.3



  • Olá,

    Atualizei o PfSense 2.2.5 para o 2.3, após atualizar meu Squid parou, não consigo nem desinstalar e muito menos reinstalar.

    Também estou com o seguinte crash report:

    –----------------------------------------------------------------------
    Crash report begins.  Anonymous machine information:

    amd64
    10.3-RELEASE
    FreeBSD 10.3-RELEASE #6 05adf0a(RELENG_2_3_0): Mon Apr 11 18:52:07 CDT 2016    root@ce23-amd64-builder:/builder/pfsense-230/tmp/obj/builder/pfsense-230/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP Stack trace:
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  1. {main}() /etc/rc.start_packages:0
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  2. sync_package() /etc/rc.start_packages:66
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  3. eval() /etc/inc/pkg-utils.inc:597
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  4. squid_resync() /etc/inc/pkg-utils.inc(597) : eval()'d code:1
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  5. squid_resync_antivirus() /usr/local/pkg/squid.inc:1991
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  6. squid_check_antivirus_dirs() /usr/local/pkg/squid_antivirus.inc:314
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  7. squid_chown_recursive() /usr/local/pkg/squid_antivirus.inc:85
    [12-Apr-2016 20:37:22 America/Fortaleza] PHP  8. chown() /usr/local/pkg/squid.inc:132
    –------------------------------------------------------------------------------------------------------------------------------------------------------------



  • Essa era minha preocupação. Vou reinstalar do zero!



  • Tive os mesmos problemas em meu ambiente de homologação, sobre o Squidguard o pacote dev não e suportado pela nova versão.



  • @iranrl:

    Tive os mesmos problemas em meu ambiente de homologação, sobre o Squidguard o pacote dev não e suportado pela nova versão.

    O squidguard-dev não existe pq foi integrado em um único pacote como descrito no link abaixo:

    squidGuard / squidGuard-devel - the squidGuard packages have been consolidated into a single option. The squidGuard-devel version no longer exists.
    https://doc.pfsense.org/index.php/2.3_Removed_Packages



  • Resolvi o problema.O Squid parou de uma forma que eu não conseguia nem atualizar ele e muito menos desinstalar. Consegui remover o Squid-Guard. Já o Squid quando tentava removê-lo dava erro. Mas consegui reinstalar depois. Quando tentava instalar o Squid pelo gerenciador de pacotes do Pf fui olhando em que parte a instalação parava, percebi que o Pf tentava criar as pastas i-cap e i_cap em dois lugares distintos mas sem sucesso pois já haviam arquivos (não pastas) com esses nomes. Fui na pasta que informava no log de instalação e apaguei os arquivos manualmente por SSH. Assim a instalação conseguiu criar as pastas e concluiu com sucesso.


Log in to reply