Cannot Install from USB [SOLVED!]



  • Hey Everyone,

    I have been trying for months to install pfSense(many versions) from USB and in each instance, it has not been successful.  I can however, successfully install from CD.

    I have tried set kern.cam.boot_delay="10000" without success.

    Below is a screenshot of the errors that appear during the install boot up.





    ![Motherboard model.jpg](/public/imported_attachments/1/Motherboard model.jpg)
    ![Motherboard model.jpg_thumb](/public/imported_attachments/1/Motherboard model.jpg_thumb)


  • Rebel Alliance Developer Netgate

    Maybe that port is on a USB controller that pfSense (well, FreeBSD) doesn't like. Try a different set of USB ports – especially if those are USB 3 ports.



  • I have the same problem installing from USB. I tried the USB 2.0 ports and the USB 3.0 ports. I get the same error. So I tried to install from disk and I got the same message. A bigger problem is that at the mountroot> prompt I cannot type anything. The USB keyboard does not work.


  • Rebel Alliance Developer Netgate

    Have you tried different USB memsticks?

    If it can't mount root it's because it cannot see the device from which it booted for one reason or another. Usually it's because the controller itself is not supported, but I could see it being the USB drive also if it was not a standard USB mass storage style device.



  • Thanks.  Here is the Link to the hardware.  http://www.qotom.net/goods-121-QOTOM-Q100S+Micro+PC.html

    Another test I did was to us a Windows usb boot this I have and I could start up no issues and run my Windows usb boot media no issues(yeah, I know two different OSes, right?).

    I'm s\checking in the FreeBSD forum like you referenced.  Just in case :)



  • Try an old 1GB USB stick, if you can't find one, try an old 2GB USB stick.

    I have experienced similar problems reflashing MIPS hardware from USB. Old USB flash sticks less than 2GB usually work but new ones 2GB and upwards don't. I guess inside the stick is a Linux core that is managing wear levelling and the delivery of 2GB of storage from 8GB or more of storage that failed manufacturing production tests at the full capacity.

    Youtube Video

    If you find an old 1GB stick that works, keep it safe.



  • Thanks.  So far that did not work nor did running it from a USB CD rom drive.  I get the same errors.

    I think it may be the hardware which is unfortunate .

    I have booted with an external DVD drive with pfSense 2.3 and still the same errors appear..

    Anyone one have any thoughts?  Would love to get this up and running.  For the price I couldn't go wrong :)




  • Tested my system with Ubuntu desktop 14.03 LTS and it boots, installs and works 100%.

    Is there is an issue with pfSense and hardware?

    I am even using the same USB flash drive to make the bootable installer.



  • A better test would be FreeBSD 10.3.

    If it will boot  with that, then you should be able to make pfSense work.



  • I have tried 10.3 and 10.1 of FreeBSD. I have cross thread going on the FreeBSD site on this issue and so far only pfSense and FreeBSD appear to be the non functioning systems.  Ultimately this is so that I can run pfSense but understanding that pfSense is built on FreeBSD, I'm hoping either would see the issue.  Its just odd(I think)



  • If you can't get FreeBSD to run, the chances of pfSense working are slim (to nil).

    I understand your goal is to get pfSense working (that should be everyone's goal, shouldn't it !), but since it's based on FreeBSD your stuck if FreeBSD won't load.



  • The issue here seems to be just booting from USB and that can worked around. Try to find another system that can boot pfSense install media and do the install on that system using the HDD from the system you're now trying to use unsuccessfully. Then just move the HDD from that system to the system that you're going to use as the real firewall and it should work just fine. FreeBSD (and pfSense) is unlike MS Windows in that regard that you can move bootable installations between systems and it will still boot assuming /etc/fstab entries are done with filesystem labels.



  • Maybe the problem is creating a bootable USB file…  Take a look here:  https://oitibs.com/pfsense-usb-install-guide-rufus/



  • Thanks everyone the issue has been solved.  It was the USB flash drives, possibly in conjunction with the application I was using to make the installer. That YouTube video was an eye opener and I also used rufus.

    I have always used unetbootin with success plus Kingston USB flash drives.  Not sure why it started failing but now that I have switched to a 4GB verbatim drive I had kicking around and everything works 100%.


Log in to reply