Freeradius won't start after PF 2.3 update



  • Yay 2.3 update.

    After updating it looks like my freeradius service won't start.  I've tried reinstalling the service.  I did get a crash report and clicked to submit it to the developers and haven't been able to find the page with the error again.  The service still isn't starting and I  did not see anything in the system logs.



  • Same issue here.



  • Glad to see I'm not the only one.  I wish I would have known that the crash report would delete the report from my local PF box before I sent it (or at the very least make it hard to find).  If anyone is having this same issue and has the crash data I'd be interested to see what it says.



  • I have the same problem, and I found a temporary solution. Log in to the console, press 8 for the shell and issue the following command:

    radiusd -f -d /usr/local/etc/raddb
    

    This will start FreeRADIUS, but the fix is temporary and will be undone if you reboot your router, or stop FreeRADIUS through the WebUI.



  • Thanks for the reply Jørn Åne.  I tried manually starting it from command line like you suggested and it works.  Just a word of warning for anyone else trying, I would recommend doing it from the console or via putty.  When I tried running the command from the web ui it froze my session and I had to restart the browser.

    Beyond the service showing as running I also confirmed I could login to radius with my credentials.

    Hopefully they will fix the automatic starting and starting from the web fixed soon.



  • @Jørn:

    radiusd -f -d /usr/local/etc/raddb
    

    worked for me, thanks


  • Rebel Alliance



  • I apologize ptt, I did not see this post while searching the forums/bugs. Thank you for bringing it up since it does bring more light to the specific radius issue.



  • Thanks, ptt! The solution in that thread seems to be lasting, so I think it's a better solution than mine.

    rm /tmp/radiusd_start.lock
    

    After running that, you will be able to start FreeRADIUS from the WebUI. You can run that command both from the WebUI or from the console, it won't make your browser hang.

    It doesn't matter if you've used the previous command before, this fix will work in both cases.


    About the hanging browser problem, it should work if you run the radiusdcommand without -f, but I haven't tried that. I think it's a bit scary to run shell commands through a browser.  :o
    But you won't need the radiusd command anymore when you've applied this fix. ;D


  • Rebel Alliance

    You're welcome !

    Thanks goes to @cmb ;)



  • I have the same problem, radius showing in services as stopped and I cant start it from the gui.

    I have done this: rm /tmp/radiusd_start.lock

    which did not make any difference,

    and this: radiusd -f -d /usr/local/etc/raddb

    which gives me this:

    [2.3.1-RELEASE][root@pfSense.skh]/root: radiusd -f -d /usr/local/etc/raddb
    gdbm fatal: Unexpected end of file

    Has anyone any further suggestions?


Log in to reply