[2.3] Need to install apcupsd (solved)



  • Hi,

    So I upgraded to 2.3 from 2.2.6 which went flawless, thanks you for that. Now onto my little issue, the apcupsd package is no longer supported in 2.3 which isn't the end of the world but I need to figure how to install the program apcupsd without breaking anything in pfsense.

    So I figure I should ask if anyone has a solution to install apcupsd as I know very little about FreeBSD and don't want to take best guess approach just yet.

    Thanks in advance.



  • OK so apparently I missed this post: https://forum.pfsense.org/index.php?topic=104738.0 and got apcupsd install. Last problem, where does pfsense 2.3 rc exist so I can do this part of the instructions?

    Add apcupsd_enable=YES to your /etc/rc.conf[.local] to have apcupsd
    starting up at boot time.
    
    


  • /etc/rc.conf.local

    Just like it says :)



  • If only it was that simple. I created the rc.conf.local in /etc/ as it didn't exist but upon reboot it does not start so I am guessing pfsense handles rc.conf different than the instructions.

    Thanks for the reply.



  • strange, I had to stick a command in /etc/rc.conf.local on 2.3 to get xen guest utilities to start on boot and it works as expected. I'd check your system logs to see if it's attempting to start but encountering some type of issue



  • Nothing is showing in the system log or apcupsd log. So I am guessing it isn't looking at the file (rc.conf or rc.conf.local). The pfsense wiki doc (https://doc.pfsense.org/index.php/Installing_FreeBSD_Packages) says that this isn't supported by the dev's so I won't expect an answer from them. I am now trying to figure out what a 'custom startup script' would look like as stated in the note about start up.

    Edit:
    https://doc.pfsense.org/index.php/Executing_commands_at_boot_time
    Wow, the solution was so simple I missed it. Shellcmd package, add apcupsd command to it. Done and solved.



  • Hi, I'm new to this forum.
    I hope you can help me.
    CoinTos can you post me same example of apcupsd command you use on Shellcmd?
    Thank's in advance.


Log in to reply