V2.3 Getting rrd error in logfile same as closed bug#6053 [Solved]



  • Hello!

    Upgraded one of my boxes yesterday from 2.2.6 to v2.3 -release (amd64).

    Almost every startup or reboot i get some error messages about update of rrd graph that fails.
    One message for every graph.

    php-cgi 		rc.bootup: The command '/usr/bin/nice -n20 /usr/local/bin/rrdtool update /var/db/rrd/system-mbuf.rrd N:U:U:U:U' returned exit code '1', the output was 'ERROR: /var/db/rrd/system-mbuf.rrd: illegal attempt to update using time 1460567396 when last update time is 1460572889 (minimum one second step)'
    

    This one is from a reboot only and the timestamps are more then 5000s apart.
    The bug#6053 have the same error and is closed.

    /Best regards illern.



  • could it be that your BIOS-time is 1.5 hours into the future ? setting it to the correct time will most likely remove the error on boot (better a minute in the past, then the future)

    graphs are started before NTP kicks in to adjust the clock to the correct time.



  • Thanks heper for pointing me in the right direction.

    This pfsense is running on a vm machine under virtualbox.
    There is a setting for the bios clock if it will send UTC or local time to the vm machine.
    I had it on Local and it needed to be on UTC for pfsense.

    Changed it and waited out the last update time of rrd and then the reboots are ok.

    I believed my clock was Ok since I have ntp on the host server and ntp in pfsense.

    /Best regards illern.