Portal cautivo, la autentificación no funciona pfsense 2.3



  • Buenas a todos, actualice a la versión 2.3, todo funciona bien, solo que el portal cautivo ya no funciona, el portal web sí, pero cuando introduzco  Vouchers o Usuarios de FreeRadius, no hace nada, el portal web se queda en blanco y no autentifica los datos.

    Este es mi código, el archivo que se llama login.html, así tal cual lo tenía subido a pfsense, siempre funciono correctamente, hasta ahora que actualice a la versión 2.3 de pfsense



  • Ya lo he resuelto, en esta nueva versión agregaron una nueva línea de código “$PORTAL_ZONE$”, solo agregue esta línea de código dentro  del form method

    Para quien pueda servirle, aquí la solución



  • Hola, yo esta mañana me estoy volviendo loco, no se porque , en tres clientes se ha actualizado solo, en uno el squid ha dejado de funcionar…sopresa...
    Y lo peor es que en dos hoteles se ha caido el portal cautivo, ha pasado de todo, he visto tambien de poner esas lineas, lo gracioso, es que con la web por defecto tampoco funcionaba, y algo mas raro, es que por mucho que ponga la red HOTSPOT dentro del portal cautivo, cuando le digo que me muestre la web para la autenticación, se va a la lan...es decir:
    deberia ir a: 172.16.3.254:8002/?zone=hotspot
    y va a :  192.168.2.254:8002/?zone=hotspot

    y no hay forma de hacerlo funcionar....alguna ayuda por favor!!!!!!!!!!!!



  • @mansi:

    Hola, yo esta mañana me estoy volviendo loco, no se porque , en tres clientes se ha actualizado solo, en uno el squid ha dejado de funcionar…sopresa...
    Y lo peor es que en dos hoteles se ha caido el portal cautivo, ha pasado de todo, he visto tambien de poner esas lineas, lo gracioso, es que con la web por defecto tampoco funcionaba, y algo mas raro, es que por mucho que ponga la red HOTSPOT dentro del portal cautivo, cuando le digo que me muestre la web para la autenticación, se va a la lan...es decir:
    deberia ir a: 172.16.3.254:8002/?zone=hotspot
    y va a :  192.168.2.254:8002/?zone=hotspot

    y no hay forma de hacerlo funcionar....alguna ayuda por favor!!!!!!!!!!!!

    usas free radius?
    https://forum.pfsense.org/index.php?topic=109850.0

    yo volví a escribir el código del portal cautivo, y solamente así funciono



  • Yo también tengo el mismo problema, probare con la solución que das, y dare mis resultados gracias. saludos!!!



  • Si ya quedó trabajando mi Portal Cautivo.

    Quedó asi mi codigo

    <form method="post" action="http://192.168.10.1:8002/index.php?zone=cpzone">

    User  :

    Pass  :

    Ticket:

    -->

    </form>