Slow Down Since Update



  • Last night I updated to 2.3 and now my user are complain that remote access via HTTP to the office is very slow.  Speed test are the same from yesterday and today also i have the same number of users on the remote server.  The ONLY change is the update to 2.3.  I am not really sure how to troubleshooting this problem other then rolling back. Here is my setup

    • I have two firewall running CARP and the user are connecting to the CARP IP.
    • 2.3-RELEASE (i386)
    • CPU Type Intel(R) Pentium(R) CPU G6950 @ 2.80GHz  2 CPUs: 1 package(s) x 2 core(s)
    • 19% (18904/98000)
    • Load average 0.12, 0.15, 0.15

    Also last night after I updated I also notice the VNC to my the office also seamed slowed.  This only looks to be a problem with the servers with CARP as the other server I have with out CARP looks to be having no problems.

    Any ideas how I can trouble shoot this or correct this issue?


  • Rebel Alliance Developer Netgate

    Is the CARP status OK on both systems (Primary shows MASTER, secondary shows BACKUP)?

    Any errors in the system log? Gateways log?

    "Slowness" is difficult to diagnose without supporting info, there is no general issue we're aware of that would cause a slow down of that nature.



  • Yes both show correctly

    No there is no errors in (both) system logs

    Prime: In the gateway there is an error however that was the time I was doing the update and it was to an internal vlan switch other then that nothing.
    Secondary:  I am getting an errors in the gateway log

    Apr 14 10:43:36  dpinger  send_interval 500ms loss_interval 30000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 24.X.X.X bind_addr 24.X.X.X identifier "rogersGW "

    I agree hard to track down any idea how to get supporting info?


  • Rebel Alliance Developer Netgate

    That's not an error, it's just dpinger starting up. Unless that's happening repeatedly in a loop, probably nothing to worry about.

    You could try taking a packet capture on WAN and then on LAN looking at a "slow" connection to see if you notice anything out of the ordinary.



  • Thanks for the help.  I did that before and do not see anything.  I am going to run some test here (install 2.2.6) and see if I can see a difference and get more information.



  • I might have worked out the issue.  I had snort on the machine and I saw other people are having problem with that package.  What I did was delete the snort package and based on my users they say it is back to normal.

    Not sure if this helps anyone and I will still run some test to see but looks like the removal of snort might have fixed it

    Paul