Cant connect serial to pfsense on Netgate m1n1wall 3E 2C3



  • Hi,

    I've been using pfsense on a pc before this, and i've decided to get the embedded machine to use in the office.

    I am having problem connecting the machine using serial console on hyperterminal or minicom using this setting

    Baud rate: 9600
    Data: 8 bit
    Parity: None
    Stop: 1 bit
    Flow control: None

    I've tested the serial cable with my switch and it works perfectly.

    Being frustrated trying to connect to the netgate using serial, i tried my luck with LAN and walla, the dhcp is working. so i could enter the pfsense web management. by looking at the url/status.php i can see that every time i tried connect my serial cable there will be new entry of the console management in the status page.

    Enter an option:
    
    FreeBSD/i386 (pfSense.local) (console)
    
    *** Welcome to pfSense 1.2-RELEASE-embedded on pfSense ***
    
      LAN*                     ->	vr0	->	192.168.1.1
    
      WAN                      ->	vr1	->	0.0.0.0(DHCP)
    
     pfSense console setup
    ***********************
     0)  Logout (SSH only)
     1)  Assign Interfaces
     2)  Set LAN IP address
     3)  Reset webConfigurator password
     4)  Reset to factory defaults
     5)  Reboot system
     6)  Halt system
     7)  Ping host
     8)  Shell
     9)  PFtop
    10)  Filter Logs
    11)  Restart webConfigurator
    12)  pfSense PHP shell
    13)  Upgrade from console
    
    Enter an option:
    

    any idea how do i fix the problem??

    your help is much appreaciated.



  • Have you tried with a baud rate of 38400?
    http://rockpenguin.wordpress.com/2008/02/23/installing-pfsense-on-the-alix2c1/
    The article pertains to the 2C1, but it may be worth a shot.



  • yup, i tried baud rate of 38400, but there's no luck



  • I'm not sure how they are setting up the boxes, but the default for the Alix2/3 is 38400 8N1, flow control = none or xon-xoff.
    Try connecting the serial at 38400 and rebooting. You should get the memory test, if you see garbage characters, the baud rate is wrong. Press S during the memory test and then press 9 to set the rate to 9600 then Q to quit and save. Disconnect and try again at 9600.



  • dotdash, i will try the solutions that you given. hopefully it works.



  • problem solved,

    I've tried what dotdash suggested, but it is weird because the url that Contingency gave was similar.

    Thank you.


Log in to reply