Kein IPv6 mehr im LAN nach Update 2.2.6 -> 2.3



  • Hallo Zusammen,

    habe meine APU gestern von der Version 2.2.6 auf 2.3 hochgezogen. Unter der Version 2.2.6 hatte ich schon IPv6 aktiviert gehabt und aktiv im LAN genutzt.
    Bin bei der Telekom und bekomme von meiner FritzBox ein /56 Netz durchgereicht was bisher super funktioniert hatte.

    Damals bin ich nach dieser Anleitung vorgegangen –> https://blog.veloc1ty.de/2015/08/22/pfsense-ipv6-delegation-hinter-fritzbox/

    Nach dem Update gestern war dann keine IPv6 Adresse mehr an der pfSense zu sehen. Wenn ich nach der Anleitung erneut vorgehe bekomme ich kein IPv6 Netz von der FritzBox vergeben.
    Im Forum hier bin ich dann auf ein paar Tipps gestossen (von einem /60 auf /56 hoch, nur noch "Send IP Prefix behind" am WAN Port aktiv) und habe nun wenigstens wieder am WAN Port eine IPv6 Adresse.  Leider bekomme ich immer noch keine IPv6 Adresse am LAN Port der pfSense und somit auch keine IPv6 Adressen mehr ins gesamte LAN.
    Muss zusätzlich der DHCPv6 Server aktiviert werden ?

    Hier meine aktuelle Config:

    
          WAN / Internet
                :
                : Telekom
                :
          .-----+-----.	  Externe Telekom IPv6 Adresse:
          |  FritzBox |       2003:XXXX:ae20:XXXX::/56
          '-----+-----'
    	      |
    	FB  | 192.168.217.1
            WAN | 192.168.217.2 / 2003:XX:ae20:XXXX:20d:XXXX:fe33:XXXX 
    			|
          .-----+-----. 
          |  pfSense  +
          '-----+-----' 
                |
            LAN | 172.16.17.254 / KEIN IPv6 mehr vorhanden!!!
                |
          .-----+------.
          | LAN-Switch |
          '-----+------'
                |
        ...-----+------... (Clients/Servers)
    	        172.16.17.0 /24
    
    

    pfSense Screenshots:


    Würde natürlich sehr gerne wieder IPv6 im Netz nutzen können. Wie sieht es bei euch aus, geht IPv6 nach dem Update ?
    Bin für jeden Tipp dankbar  ;)



  • Hab es jetzt hinbekommen  8)
    WAN seitig habe ich jetzt ein /60 Netz genommen und "Request only an IPv6 prefix" aktiviert.



  • Das Problem scheint damit wohl doch nicht behoben. :-[

    Sobald ich an der WAN Schnittstelle was ändere (egal was) und auf Save klicke ist IPv6 am WAN weg und somit auch im LAN (wg. Tracking)
    Auch nach einem neustart der pfSense ist es Glück wenn ich eine IPv6 Adresse erhalte. Mal tut es, mal nicht.
    Schade - in der 2.2.6 hatte das super funktioniert.

    Hat einer von euch IPv6 erfolgreich mit der 2.3 im Einsatz ?
    Bin für jeden Tipp dankbar  ;)


  • LAYER 8 Moderator

    Hat einer von euch IPv6 erfolgreich mit der 2.3 im Einsatz ?

    Ja aber aus der "Not" heraus, fixe Prefixe haben zu wollen/müssen, nur mit einem Tunnel, daher eher für den speziellen Fall uninteressant - leider.
    Hört sich aber eher nach einem Fehlverhalten des IPv6 RD an. Oder hat sich ggf. an dem Gerät vornedran was geändert? Andere Masken die jetzt ankommen? Update bekommen?



  • Oder hat sich ggf. an dem Gerät vornedran was geändert? Andere Masken die jetzt ankommen? Update bekommen?

    Davor hängt die FritzBox welche immer noch die selbe Netzgröße liefert. Ich kann 100% sagen das es an der pfSense 2.3 liegt, da nach dem Update die zickerei los ging. In dem Zeitfenster des Updates wurde die FritzBox nicht neugestartet und auch nicht vom Internet getrennt so das die selben IPv6  Adressen vor - wie auch nach dem Update anlagen.
    Was dann mit der 2.3 leider nicht mehr funktioniert.



  • Ich bin von dem Problem ebenfalls betroffen, kann aber leider auch nichts zu einer Lösung beitragen.



  • Will dem ganzen mal mehr auf dem Zahn fühlen. In der WAN Schnittstelle habe ich nun das IPv6 Debug (Start DHCP6 client in debug mode) aktiviert. Leider ist mir nicht klar wo genau ich die Logs finden kann  ::)

    Zumindest habe ich das hier unter dem Routing Teil der Logs gefunden:

    Apr 20 19:54:14 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:54:06 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:54:03 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:54 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:44 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:38 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:30 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:23 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:13 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:09 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:06 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:53:02 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:52:57 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:52:50 	radvd 	42811 	sendmsg: Permission denied
    Apr 20 19:52:44 	radvd 	42811 	sendmsg: Permission denied 
    


  • Bin immer noch an der IPv6 Thematik dran.
    Was mir aufgefallen ist, sollte die WAN Schnittstelle nicht auch wenigstens eine Link-lokal IPv6 Adresse haben ?

    
    *** Welcome to pfSense 2.3-RELEASE-pfSense (amd64) on pfsense ***
    
     WAN_PORT (wan)  -> re2        -> v4: 192.168.217.2/24
     LAN_BRIDGE0 (lan) -> bridge0    -> v4: 172.16.17.254/24
     LAN_PORT (opt1) -> re1        ->
     WLAN_BRIDGE0 (opt2) -> ath0_wlan0 ->
     WLAN_GUEST (opt3) -> ath0_wlan1 -> v4: 172.16.19.254/24
     PIA_VPN (opt4)  -> ovpnc1     -> v4: 10.104.1.6/32
     WLAN_VPN (opt5) -> ath0_wlan2 -> v4: 172.16.20.254/24
     VLAN10_DMZ (opt6) -> re1_vlan10 -> v4: 172.16.50.254/24
     VLAN20_VPN (opt7) -> re1_vlan20 -> v4: 172.16.21.254/24
    
     0) Logout (SSH only)                  9) pfTop
     1) Assign Interfaces                 10) Filter Logs
     2) Set interface(s) IP address       11) Restart webConfigurator
     3) Reset webConfigurator password    12) pfSense Developer Shell
     4) Reset to factory defaults         13) Update from console
     5) Reboot system                     14) Disable Secure Shell (sshd)
     6) Halt system                       15) Restore recent configuration
     7) Ping host                         16) Restart PHP-FPM
     8) Shell
    
    Enter an option: 8
    
    [2.3-RELEASE][root@pfsense.lan-net.local]/root: ifconfig re2
    re2: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
            options=8209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:0d:b9:33:9c:42
            inet 192.168.217.2 netmask 0xffffff00 broadcast 192.168.217.255
            nd6 options=23 <performnud,accept_rtadv,auto_linklocal>media: Ethernet 100baseTX <full-duplex>status: active
    [2.3-RELEASE][root@pfsense.lan-net.local]/root:</full-duplex></performnud,accept_rtadv,auto_linklocal></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,promisc,simplex,multicast> 
    

    Das  Neighbor Discovery ist aktiv. In der Firewall sehe ich immer wieder IPv6 Adressen welche am WAN geblockt werden auf Port 1900, 5355 usw. Nicht das noch Regeln auf dem WAN-Interface nötig sind um die v6 IP-Adressen anzunehmen ?


Log in to reply