Nmap scanning nginx timeout



  • In the new version it appears that nginx times out before nmap are results.
    I am running a fairly standard nmap from the gui with Attempt to identify service versions and Enable Operating System detection turned on and using the sync method for port testing.
    The scan is being ran against my linux box (which is in fact hosting the vm running pfsense in my case).
    Is there anyway to increase idle timeout of nginx so it doesn't quit on me before nmap finishes?



  • Anything that long-running you should run via SSH rather than the GUI. It's probably the php-fpm timeout that you're hitting, but it's already pretty long and generally wouldn't be a good idea to increase it further.



  • Agreed, but it kind of defeat the purpose of nmap package no?
    I am just fine running nmap from ssh, and the only reason I ran it through the gui is to test the functionality.
    Perhaps its a good idea to disable this package or at least give a warning to users letting them know it can't really be operated through the gui.



  • +1 for having a gui-based nmap, like before



  • That's no diff than it's ever been, there have always been nmap commands that would time out if run from the GUI because they take too long.

    When run from the GUI it ought to be backgrounded, then AJAX added to check its status and pull in the results. Pull requests welcome.



  • Would be great if it were reworked to run in the background.
    Same question applies to packet capture.
    Does it also wait for the tcpdump?
    In that case we would have a similar problem and general inability to use tcpdump for long captures with the gui.



  • No. The packet capture runs tcpdump in the background separate from the GUI process.


Log in to reply