Forgot to remove Bandwidthd before updating to 2.3



  • What's the best way to remove all traces of the bandwidthd from my system?  I still see it under the Services Status Widget as being stopped and also under Diagnostics –> BandwidthD but get a 404 when I click it.

    Thank you



  • I think this question needs to be more general:
    Even though it said unsupported packages would be removed upon upgrading, that doesn't seem to have been the case.

    On my remote system, to be on the very safe side, I removed all the now missing packages manually before the upgrade. That unit seems to work fine.

    On my local system traffic doesn't flow, despite pass-all rules, I have remnants of olsrd I can't get rid of, and squid and related packages refuse to install.

    What we need is a system cleaning package..,



  • I agree.

    This is the problem I am faced with now.  Bandwidthd doesn't show up in packages and wasn't uninstalled cleanly during the upgrade from 2.2.5 to 2.3 so a package manager would help in the future, however what can we do now to clean up the old packages now?

    Thanks



  • You can cleanup any visibility of it:

    1. Diag->Backup/Restore - download the config.
    2. Keep the original config, make a copy of it on your local PC.
    3. Edit the copy of the config, search for bandwidthd and delete those sections. You will likely find a menu section, service section and a package settings section. Be careful to cleaning delete whole "chunks" including balancing end tags.
    4. Look in /usr/local/etc/rc.d for *.sh files and remove ones that are from old packages - like bandwidthd.sh (otherwise they will get run by the boot scripts)
    5. Restore the edited config (the system will reboot and implement it)

    That will get rid of the menu entry, entry in Status->Services and startup script.

    There might be binaries for the actual package itself somewhere on the system, but I suppose they will do no harm if nothing ever runs them.



  • I also did not remove bandwidthd before upgrading to 2.3, however (maybe i am blind) i don't see any leftovers from bandwidthd on my system.

    /usr/local/etc/rc.d: ls -l
    total 104
    -r-xr-xr-x  1 root  wheel  1059 Apr  6 18:52 ataidle
    -r-xr-xr-x  1 root  wheel    682 Apr  6 18:52 choparp
    -r-xr-xr-x  1 root  wheel  1181 Apr  6 18:53 dhcp6c
    -r-xr-xr-x  1 root  wheel    881 Apr  6 18:53 dhcp6relay
    -r-xr-xr-x  1 root  wheel  1005 Apr  6 18:53 dhcp6s
    -r-xr-xr-x  1 root  wheel  2747 Apr  6 19:03 dnsmasq
    -r-xr-xr-x  1 root  wheel    404 Apr  6 18:52 expiretable
    -r-xr-xr-x  1 root  wheel    588 Apr  6 18:58 gogoc
    -r-xr-xr-x  1 root  wheel    772 Apr  6 18:58 igmpproxy
    -r-xr-xr-x  1 root  wheel  11841 Apr  6 19:01 isc-dhcpd
    lrwxr-xr-x  1 root  wheel      9 Apr  6 19:01 isc-dhcpd6 -> isc-dhcpd
    -r-xr-xr-x  1 root  wheel  1828 Apr  6 19:00 isc-dhcrelay
    lrwxr-xr-x  1 root  wheel    12 Apr  6 19:00 isc-dhcrelay6 -> isc-dhcrelay
    -r-xr-xr-x  1 root  wheel    574 Apr  6 18:52 miniupnpd
    -r-xr-xr-x  1 root  wheel    878 Apr  6 18:53 mpd4
    -r-xr-xr-x  1 root  wheel    838 Apr  6 18:53 mpd5
    -r-xr-xr-x  1 root  wheel  3495 Apr  6 19:00 nginx
    -r-xr-xr-x  1 root  wheel  3752 Apr  6 18:56 openvpn
    -r-xr-xr-x  1 root  wheel    703 Apr  6 19:10 php-fpm
    -r-xr-xr-x  1 root  wheel    387 Apr  6 18:59 radvd
    -r-xr-xr-x  1 root  wheel    516 Apr  6 18:52 relayd
    -r-xr-xr-x  1 root  wheel    582 Apr  6 19:11 rrdcached
    -r-xr-xr-x  1 root  wheel  1155 Apr  6 18:59 smartd
    -r-xr-xr-x  1 root  wheel    576 Apr  6 19:15 strongswan
    -r-xr-xr-x  1 root  wheel  1255 Apr  6 19:06 unbound
    -r-xr-xr-x  1 root  wheel    523 Apr  6 18:53 xinetd
    /usr/local/etc/rc.d:

    anywhere else i should look ?

    thanks!



  • I had the same issue with BandwidthD and Vnstat2.  I did the edit config.xml and restore thing, worked fine.  I believe the obsolete packages are actually uninstalled on upgrade, leaving only the menu/services items in config.xml.



  • I think that was the case for me, it got uninstalled, as i did not see any errors.

    I just tried to access the url to view bandwidthd, and it said doesn't exist.

    went to pfsense, checke if the package is there, then i figured it out that it was uninstalled.



  • Thank you.  this worked!.


Log in to reply