[Dica] Gateway Monitoring Daemon não funcionando no pfSense 2.3 - dpinger



  • Pessoal,

    Para quem estiver tendo problemas com o "Gateway Monitoring Daemon" no pfSense 2.3, ficando sempre com o status Down, basta seguir o passo a seguir:

    Motivo:

    Alguns modens/roteadores descartam ICMP com 0 byte, e como o dpinger utiliza 0 byte como default, será necessário alterar o valor do parâmetro "data payload", que estipula quatos bytes será enviado no pacote ICMP para checagem do Gateway.

    Solução:

    1- Vá em System -> Routing
    2- Clique para editar o Gateway
    3- Altere o campo "Data Payload" de 0 para 1
    4- Salve e aplique a modificação
    5- Reinicie o dpinger

    Espero ter ajudado!



  • Valew Sorriso,

    Deu certo mesmo. Após atualizar da versão 2.2.6 para a 2.3 meu monitoramento de gateway havia parado mesmo.

    Obrigado!



  • Olá Sorriso, aqui funcionou perfeitamente!
    Era isso mesmo que faltava!

    Muito obrigado!



  • Deu certo! Valeu!



  • Parabéns, deu certo!



  • Resolvido.

    parabéns.



  • Depois de algumas horas funcionando, parou novamente.

    Aconteceu com mais alguém?



  • @hugoeyng:

    Depois de algumas horas funcionando, parou novamente.

    Aconteceu com mais alguém?

    Verifica como está a configuração novamente.

    Aqui está funcionando até hoje.



  • @Sorriso:

    @hugoeyng:

    Depois de algumas horas funcionando, parou novamente.

    Aconteceu com mais alguém?

    Verifica como está a configuração novamente.

    Aqui está funcionando até hoje.

    Posso imaginar que é uma solução "não solução", mas eu coloquei em "Monitor IP" o IP da própria placa de rede, e claro que enquanto a placa estiver funcionando aquele gateway nunca será tido como "down".

    Acho que é equivalente a desabilitar o "Gateway Monitoring".

    Isso faz com que essa conexão nunca seja realmente testada, o que me leva a um outro problema, que é o caso da conexão cair e e ela não ser descartada em favor da outra. Ou seja, eu fico sem contingência.



  • @hugoeyng:

    @Sorriso:

    @hugoeyng:

    Depois de algumas horas funcionando, parou novamente.

    Aconteceu com mais alguém?

    Verifica como está a configuração novamente.

    Aqui está funcionando até hoje.

    Posso imaginar que é uma solução "não solução", mas eu coloquei em "Monitor IP" o IP da própria placa de rede, e claro que enquanto a placa estiver funcionando aquele gateway nunca será tido como "down".

    Acho que é equivalente a desabilitar o "Gateway Monitoring".

    Isso faz com que essa conexão nunca seja realmente testada, o que me leva a um outro problema, que é o caso da conexão cair e e ela não ser descartada em favor da outra. Ou seja, eu fico sem contingência.

    Realmente não é uma solução e eu recomendo fortemente que isso não seja feito.  ;D

    Mas você pode colocar um IP válido como "monitor IP", como por exemplo um servidor do google, para efetuar os testes de conexão.



  • @Sorriso:

    @hugoeyng:

    @Sorriso:

    @hugoeyng:

    Depois de algumas horas funcionando, parou novamente.

    Aconteceu com mais alguém?

    Verifica como está a configuração novamente.

    Aqui está funcionando até hoje.

    Posso imaginar que é uma solução "não solução", mas eu coloquei em "Monitor IP" o IP da própria placa de rede, e claro que enquanto a placa estiver funcionando aquele gateway nunca será tido como "down".

    Acho que é equivalente a desabilitar o "Gateway Monitoring".

    Isso faz com que essa conexão nunca seja realmente testada, o que me leva a um outro problema, que é o caso da conexão cair e e ela não ser descartada em favor da outra. Ou seja, eu fico sem contingência.

    Realmente não é uma solução e eu recomendo fortemente que isso não seja feito.  ;D

    Mas você pode colocar um IP válido como "monitor IP", como por exemplo um servidor do google, para efetuar os testes de conexão.

    Entendo os motivos pra que não seja feito. :)  Estou mantendo isso pois estou monitorando a ADSL e ela realmente não está caindo. Então continuo trafegando por ela mesmo que no pfSense, em se monitorando um IP externo, apareça como down.

    Já usei o IP 8.8.8.8 da Google e outros mais. Com todos, no pfSense a conexão aparece down.

    Estranhamente, com a outra conexão isso não acontece. Esta outra conexão não é ADSL. Ela é direta do ISP.

    Vou continuar tentando alternativas.  Obrigado pela ajuda. Se eu descobrir algo, posto aqui.



  • Sorriso, meus parabéns.

    Funcionou perfeitamente aqui. Era exatamente este o problema.

    Um abraço da comunidade.  :)



  • Na atualização para 2.3.2 o problema não ocorre mais



  • Matou a pau!!!

    Agora funcionando perfeitamente obrigado por compartilhar, o estranho é que em versões 2.2.?  funciona sem problemas.



  • @Sorriso:

    Pessoal,

    Para quem estiver tendo problemas com o "Gateway Monitoring Daemon" no pfSense 2.3, ficando sempre com o status Down, basta seguir o passo a seguir:

    Motivo:

    Alguns modens/roteadores descartam ICMP com 0 byte, e como o dpinger utiliza 0 byte como default, será necessário alterar o valor do parâmetro "data payload", que estipula quatos bytes será enviado no pacote ICMP para checagem do Gateway.

    Solução:

    1- Vá em System -> Routing
    2- Clique para editar o Gateway
    3- Altere o campo "Data Payload" de 0 para 1
    4- Salve e aplique a modificação
    5- Reinicie o dpinger

    Espero ter ajudado!

    Aqui deu certo. Obrigado.



  • Muito Boa a dica.. Aqui resolvou tudo..  ;D


Log in to reply