How do i force pfsense to use specific DNS



  • I ran google's namebench application to find a fastest DNS server. whenever i update "DNS Server Settings" with the results i notice its still using whatever my ISP provided. i tried manually updating resolv.conf on the firewall and running the test again and that works for a short  time because the keeps reverting to what the ISP provided. Is there something that im missing.  i would like to 127.0.0.1 as primary and use whatever the results are as secondary/tertiary.

    Any help would be appriciated. Thanks.

    PS im running 2.3 if that make a difference.



  • I am pretty sure it should be enoguh to specify the DNS servers under System -> General setup



  • Yea, and uncheck "Allow DNS server list to be overridden by DHCP/PPP on WAN" (2.2.6 calls it this way).


Log in to reply