Internal hostnames doesn't work 2.3



  • So as so many other did when 2.3 was released I was also clapping my hands out of excitement for the new GUI.
    but after i updated from 2.2 to 2.3 then all of my internal hostnames there was controlled by pfSense's dns resolver stopped working?

    when i try to ssh and use a hostname then i get this respond

    ssh root@puppet.home
    ssh: Could not resolve hostname puppet.home: Name or service not known
    
    

  • Rebel Alliance Developer Netgate

    DNS Resolver or DNS Forwarder?
    Host overrides or are they coming from DHCP?



  • for reference (working for me)

    after upgrading from 2.2.6 to 2.3

    I had to enable DNS resolver to bring names from DHCP assigned dynamically, and DHCP reserved (sorry forgot the actual names used by pfsense)
    it was two separate check boxes.

    –- Edit ---
    Found the correct names
    I had to enable:

    • Register DHCP leases in the DNS Resolver
    • Register DHCP static mappings in the DNS Resolver

    both inside DNS Resolver / General Settings



  • Thanks! this did solve the problem

    @AllGamer:

    for reference (working for me)

    after upgrading from 2.2.6 to 2.3

    I had to enable DNS resolver to bring names from DHCP assigned dynamically, and DHCP reserved (sorry forgot the actual names used by pfsense)
    it was two separate check boxes.

    –- Edit ---
    Found the correct names
    I had to enable:

    • Register DHCP leases in the DNS Resolver
    • Register DHCP static mappings in the DNS Resolver

    both inside DNS Resolver / General Settings


Log in to reply