Squid + Squid Guard não inicia pfsense 2.3



  • Fala pessoal

    mais alguém esta com o mesmo problema no pfsense 2.3 ?
    o squid e o squidGuard não inicia de jeito nenhum.
    Já desinstalei o squid e o squidGuard, apaguei as pastas deles (/usr/local/etc/squid  e  /usr/local/etc/squidGuard) e instalei novamente e nada, mando atualizar a blackList e aparece "pfSense has detected a crash report or programming bug. Click here for more information." na Dashboard com o erro abaixo.
    E mais, os serviços clamd e c-icap tambem não startam.

    Crash report begins.  Anonymous machine information:

    amd64
    10.3-RELEASE
    FreeBSD 10.3-RELEASE #6 05adf0a(RELENG_2_3_0): Mon Apr 11 18:52:07 CDT 2016    root@ce23-amd64-builder:/builder/pfsense-230/tmp/obj/builder/pfsense-230/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [19-Apr-2016 13:00:11 Etc/UTC] PHP Stack trace:
    [19-Apr-2016 13:00:11 Etc/UTC] PHP  1. {main}() /tmp/squidGuard_blacklist_update.sh:0
    [19-Apr-2016 13:00:11 Etc/UTC] PHP  2. sg_reconfigure_blacklist() /tmp/squidGuard_blacklist_update.sh:5
    [19-Apr-2016 13:00:11 Etc/UTC] PHP  3. sg_update_blacklist() /usr/local/pkg/squidguard_configurator.inc:2095
    [19-Apr-2016 13:00:11 Etc/UTC] PHP  4. squidguard_ramdisk() /usr/local/pkg/squidguard_configurator.inc:2131
    [19-Apr-2016 13:00:11 Etc/UTC] PHP  5. mkdir() /usr/local/pkg/squidguard_configurator.inc:1978

    Filename: /var/crash/minfree
    2048



  • Estou com o mesmo problema :(



  • Instalação nova ou atualização?
    Se for atualização como mudou o formato de pacotes, pode ser "lixo" que tenha ficado.



  • No meu caso é atualização



  • @mbotacin:

    No meu caso é atualização

    Não recomendo atualizar quando muda a versão, mudou pacotes, formato, etc…
    Faz instalação limpa e restaura o backup.



  • Estou com o mesmo problema em um servidor que acabou de ser formatado.

    Versão atualizada do Squid e SquidGuard.



  • Fiz uma instalação nova e atualizei para a versão 2.3.1 e estou com o mesmo problema.



  • Tive que instalar a versão 2.3 e deixar de fazer a atualização para a versão 2.3.1



  • Boa tarde sou novo aqui no forum, tive esse problema ao fazer o update da versao 2.1.5 para a versão 2.3.4, porem fiz esses procedimentos de limpar o cache do squid e comigo resolveu.

    rm -fr /var/squid/cache/*
    squid -z
    /usr/local/etc/rc.d/squid.* start

    Espero que possa ajudar alguem !