RESOLVED:e-mail notifications – it's not even trying



  • I recently installed 2.3 and decided to try to set up e-mail notifications. I've never had this configured before.

    My settings:

    E-Mail server: smtp.gmail.com
    SMTP Port of E-Mail server: 587
    Secure SMTP Connection: Enable STARTTLS
    From e-mail address: example@gmail.com
    Notification E-Mail address: example-notifications@gmail.com
    Notification E-mail auth: example
    Notification E-Mail auth password: Set correctly, verified on Gmail
    Notification E-Mail auth mechanism: PLAIN

    I've been using the Test SMTP Settings button for all testing.

    So after tinkering with these settings for about half an hour, I decided to see what tcpdump says. I ran it on my WAN interface and filtered by port 587. Hit the Test button, and no packets were sent. I tried with various other combinations, and with sniffing on my other interfaces, and still nothing. It's like the button isn't doing anything.

    Is there something underlying in the system that is broken? Is a certain package required for email notifications to work? Any thoughts?


  • Rebel Alliance Developer Netgate

    Does the firewall have functional DNS? Can it resolve smtp.gmail.com from Diagnostics > DNS Lookup?

    Nothing is fundamentally broken with the e-mail notifications, I have them on for 2-3 of my test VMs and I receive them OK.



  • DNS resolves it correctly.

    To add to the the troubleshooting, I changed the destination to a host on my network and dumped traffic there (the pfsense box has a lot of interfaces, so this seemed simpler.) No good. It's not attempting the connection.

    Any other thoughts?



  • Ok, this was resolved. I added several logging statements to the PGP files and found that pfsense thought it was in booting mode (it had been up for 14 hours or so already.) Rebooted and all is good.


Log in to reply