Browser access lockup



  • My clients are all fixed IP with defined DNS server, so I have the DHCP server turned off.
    The setup is only a firewall for broadband access without anything more complicated.

    I have no need to define a DNS server within pfSense.

    When the dashboard page is refreshed, there is WAN traffic probably due to the auto-update function
    which I am unable to stop with the "stop autoupdate click box" on the update page. 
    Problem 1 - The "stop autoupdate" function does not work for me.

    If I leave the DNS server field blank, and I assume also if the DNS server goes down,
    the auto-update process cannot find the update server.
    After a few refreshes (around six to ten I think) of the dashboard page then browser
    access locks up and does not respond to the mouse or keyboard.

    Looking at the processor graph shows an increasing number of running processes when this happens,
    until lock up occurs.  After a Reboot all is back working, until the dashboard page is again refreshed . . ..

    There are two problems here, can anyone repeat this?

    EDIT - Should have said,  this refers to the 2.3  RELEASE  version firmware.

    J.



  • Yeh, the background processing of the update check happens anyway (just the result is not displayed on the dashboard GUI).
    Redmine https://redmine.pfsense.org/issues/6212
    Pull request https://github.com/pfsense/pfsense/pull/2890

    As far as I can see that stops the background processing.
    Please test and see if that fixes it.



  • Thanks for confirm that the update check cannot be disabled with the check box on the page.

    Not sure how to do your mod. and am going to have to leave things for toay.

    I modified / edited pfSense repo file - set enabled to no which stops the update checking.  (Horrible kludge!!  NOT reccomended!!)
    It would be nice if the disable box could be made to work.

    Short version is that I don't have an ongoing  problem.

    So far as browser  (dashboard page)  lock up is concerned this looks more serious, not affecting me, but there are other posts with similar and possibly related problems - if I'm correct with my analysis then a valid DNS server must always be available.  Be nice to have this confirmed - or not.

    J



  • You can install System Patches package, then add a patch to point to the commit for this fix:
    https://github.com/pfsense/pfsense/commit/d3f7004d96c274f117a0264094595c9fbe85b6f7

    Then following the bouncing ball to apply it.



  • Thanks your further help and fast response.

    Followed your instructions to apply the patch.  Got the error
    "Patch can NOT be applied cleanly", which I noted, then continued.

    The patch works, the checkbox "Disable automatic dashboard auto-update check"
    does now stop WAN activity on dashboard page refresh, and can be toggled,  which then
    results in  WAN activity and I assume  allows the auto update to take place.

    I've only done brief testing and not checked for anything else affected, however it looks like the fix is OK here.

    J.


Log in to reply