V2.3 No bandwidth field in Shaper Queue Config



  • I upgraded from 2.2.6 to 2.3 and noted that there is no bandwidth field etc when configuring the queues in the Traffic Shaper.
    The Interface config allows for setting the bandwidth, but not the queues for the interface.
    The previous bandwidth settings seem to be in effect, but there is no way of changing them in the gui.
    I am using CBQ

    Anyone else seeing this on 2.3??

    I should add that the other options such as Borrow etc are also not present.

    Btw, I do like the look of the new interface.  But, as one poster mentioned, it uses more screen space, which is minor grouse.



  • Any update on this?  I just did a fresh install of 2.3 and need to use CBQ traffic shaping.  As OP said there is no field for bandwidth on the sub-queues for the interface.

    Will someone point me in the correct direction to add the bandwidth to the queues from the command prompt?



  • I thought I was the only one that had the same problem.  I did an upgrade to the 2.3dev before it was finalized and now I'm on the 2.3.1dev and it still isn't fixed.  When I upgraded I lost some of my bandwidth settings, some had incorrect XML tags and some were just missing (I had to look at the config.xml). What I did was edit the config.xml file directly.  Do this by getting into the shell (console or ssh) and typing "viconfig"  (no quotes).  Then type "/shaper"  (no quotes, that should take you straight to the traffic shaper config).  Here's an example of what my interface queue looks like:

    
     <shaper><queue><interface>wan</interface>
                            <name>wan</name>
                            <scheduler>CBQ</scheduler>
                            <bandwidth>620</bandwidth>
                            <bandwidthtype>Kb</bandwidthtype>
                            <enabled>on</enabled></queue></shaper> 
    

    And this is one of my subqueues:

    
     <queue><name>WAN_Q_voip</name>
                  <interface>wan</interface>
                  <priority>7</priority>
                  <bandwidth>200</bandwidth>
                  <bandwidthtype>Kb</bandwidthtype>
                   <enabled>on</enabled>
                   <borrow>on</borrow></queue> 
    
    

    (I'm assuming you are familiar with using "vi" as the text editor)
    AFter you save your config, reboot.

    I hope that helps until they get this little bug fixed  :)


  • Developer Netgate

    Both the bandwidth and borrow elements were missing from CBQ queues. Those have now been restored and should appear in the next snapshot.