Slow internet connection after a few minutes



  • I have been doing a lot of speed testing. I'm on a 16x2 cable connection. My PFSense box is a 2.8ghz p4 with 768mb or ram. When ever I reboot the machine it's fast for about 5 minutes then the speeds drop off about 4-6 mb's.  If I reboot and run speed tests it's quick again. This happens everytime.  Normal for the first five minutes then slows the internet connection a bit.

    The first 5 minutes are the same speeds that I get if I connect my macbook directly to the cable modem.

    what gives?



  • I should also mention that I have tried using all three of my network cards as the wan/lan/dmz and the same thing happens no matter what the configuration. i've also crawled the log files and don't see any errors. i also checked the interfaces and they report 0 collisions and 0 errors. cpu is always very low and ram holds steady at about 64mb being used.



  • What's your pfSense config setup like? lots of extra packages?



  • the only add on I have is squid proxy. But I did in fact try and disable that to no avail. weirdest thing, blazing fast for about 3 minutes then slows a bit.



  • it seems when i reset the state tables the speed goes back up. this coincides with what happens with a reboot too. weird thing is that my state tables are set at the default of 10000 and they never go much over 100.

    any ideas?



  • the RRD states graph never shows your states maxing out?



  • I believe this is the ongoing issue with the squid package in FreeBSD 6.2.  Try installing one of the 1.2_RELEASE built on FreeBSD 6.3.  This solved our problems, however there may still be issues around squid actually serving requests from the cache correctly, but that's another issue.  Try the package and bounty forums, there are posts in both.



  • yep, disabling squid seems to fix the problem.  thanks!!



  • To Fix Squid

    add this to the /boot/loader.conf

    kern.ipc.nmbclusters=32768
    kern.maxfiles=65536
    kern.maxfilesperproc=32768
    net.inet.ip.portrange.last=65535

    or just delete it and replace with

    autoboot_delay="1"
    #kern.ipc.nmbclusters="0"
    hint.apic.0.disabled=1
    kern.hz=100
    #for squid
    kern.ipc.nmbclusters="32768"
    kern.maxfiles="65536"
    kern.maxfilesperproc="32768"
    net.inet.ip.portrange.last="65535"

    you might ask why squid is so slow? its because default configuration of pfsense is router not as a server
    thats why kern.ipc.nmbclusters="0" <- is set to zero. if you just simply remove this squid will be just fine.

    but to tune the squid i add this
    kern.ipc.nmbclusters: 32768
    kern.maxfiles=65536
    kern.maxfilesperproc=32768
    net.inet.ip.portrange.last: 65535

    i just figure out why squid is slow. but i don't like the binary package of squid. i'll be using the squid HEAD bec of the store_rewrite feature for caching youtubes videos and other video files and mp3.



  • that's great info, thanks.


Log in to reply