Lan / Wan Verbindungsproblme - NAT Reflection ?



  • Hallo zusammen!

    Hoffe ich bekomme das jetzt halbwegs verständlich beschrieben.

    Also ich habe zuhasue (im LAN) einige Server laufen. (Cloud, Webseiten, Ark, usw..)
    Ich wollte mir aus Kostengründen kein Wildcard Certificate kaufen.
    Daher laufen die Server auf unterschiedlichen Ports.

    So, als Beispiel zum Problem:
    Wenn ich mit meinem Laptop zuhause bin ist dieser mit dem W-Lan verbunden und bekommt natürlich auch eine IP aus dem LAN.
    Im Client für den Cloud Server hab ich als Server eingestellt https://meinedomain:4444
    Das funktioniert aber nicht.
    Muss wenn ich im Lan bin jedes mal umstellen auf https://LokaleIP:4444 - was sich dann natürlich mit dem https schlägt.
    Wenn ich mit dem Laptop unterwegs bin also am Laptop eine Öffentliche IP habe muss ich wieder umstellen auf https://meinedomain:4444

    Ich hoffe das war jetzt halbwegs verständlich.
    Das Problem hab ich nicht nur mit dem Cloud Server sondern mit allen.
    Als ich die PFSense noch nicht hatte war ein Linksysrouter mit DD-WRT verbaut.
    Da hatte ich das Problem nie - konnte da meine Server auch aus dem Lan mit der Öffentlichen Addresse erreichen.

    Kann mir da bitte jemand helfen?

    Besten Dank schonmal!



  • So habs hinbekommen, weiß aber nicht warum !?

    Hab bei System / Advanced / Firewall & NAT unter Network Address Translation.
    Den NAT Reflection mode for port forwards umgestellt auf Pure NAT und den Hacken bei Enable automaic outbound NAT for Reflection.

    Jetzt gehts aber hab keine Ahnung was das jetzt wirklich macht - hat da jemand eine Erklärung dazu??

    Besten Dank!


Log in to reply