Amd64 Memstick Install and Restore from nanobsd



  • Hey all,

    I installed the 2.3 release 32-bit nanobsd 4G to a flash drive and decided to add an SSD to the same system. So, I followed the following steps:

    • i386 Nanobsd install and configure

    • Backup with RRD the running config

    • Shutdown system, install SSD

    • Using memstick distro, installed the amd64 release version with VGA

    • Setup LAN to get onto the network and restored the config from above

    • In System->Advanced->Misc deselected the "Use RAM Disk" option, the Save

    The system did reboot, but when it came back up both /tmp and /var are still on UFS ramdisk. A df -k does show that / is using the SSD and /etc/fstab has entries for both / and swap. I attempted this twice.

    Is there a process I could do from the CLI to perform the same operation? Losing RRD files or DHCP leases isn't a big deal, but I'd like to get everything to use the SSD.



  • If this might be a 64Bit capable hardware, you should chose the right image and aware of the i386 images!
    And during the installation procedure it would be then wise to chose and go with the "custom install" and
    not the "Quick/Easy install" procedure!!! If you might be then creating /var and /tmp partitions the ones in
    the RAM will be not be pressed to use, for sure you should also create all other needed partitions as well.

    • create a config.xml file where the configuration will be stored in and safe it outside of the pfSense firewall
      can be then played back to any pfSense installation
    • choose your amd64 Memstick image and preapre a USB pen drive to boot and install from this then
      matching your console type
    • if all is installed and running play back the config.xml file
      All is done and finished then


  • Thanks for the response, you're describing what I did and why I did a new install (to get the proper image on my ssytem and take advantage of the 8GB of on-board RAM). Once I installed the i386 version on a i5 processor, I realized I hadn't used the amd64 version. So to rectify, I backed up my config locally (with RRD graphs), reinstalled (custom taking the default slices of of / = * and swap = 16GB), and restored the previous config.

    But since the i386 install was to a flash drive (nanoBSD 4G), I had set the ramdisk sizes accordingly. That's what I'm now trying to turn off, and doing it via the console is not working. I deselect ram disk, get the popup that the system will reboot when I hit "Save" (cool), and does exactly that.But when the system restarts, the ramdisk partitions are still being used.

    Is this something that may need to be done in single-user vs multi-user mode?



  • Looks like this is resolved in 2.3.1 as there was a bug preventing Advanced->Misc changes from being saved. Workaround in the bug comments also.

    https://redmine.pfsense.org/issues/6146


Log in to reply