Manually updated 2.2.4 to 2.2.6 and picked the wrong platform - now what


  • I had some pfSense installs that were on 2.2.4 and I wanted to get them up to 2.2.6 today.  Turned out to be a little more confusing than I thought.  First of all auto-update only wanted to serve me 2.3 so that was out the window as I was not ready for that yet.  So I tried to find a URL to download the .tgz or .gz file for 2.2.6 that matched my platform.

    I found that by going to https://www.pfsense.org/download/mirror.php?section=updates#mirrors and then browsing into the /old directory there were apparently the files I needed.

    Problem is I had an APU2 unit that was running 2.2.4 nanobsd-4g and by mistake I used
    https://nyifiles.pfsense.org/mirror/updates/old/pfSense-Full-Update-2.2.6-RELEASE-amd64.tgz

    …To update it.  The update actually went through and the firewall rebooted itself and is back online but now is running "full" instead of nanobsd.  Is that even possible?  Or maybe I was mistaken and it had been running full somehow before?? Either way I came here to ask is there a way to "switch back" to nanobsd? I am worried about the CF card dying now and I am not local to this unit and getting there will not be easy.

    thanks all for any help

  • Rebel Alliance Developer Netgate

    You can't switch from one to the other that way. If it accepted that file, it had to have already been running a full install.

    APU would not likely have been running NanoBSD anyhow, though maybe on an SD card. It doesn't have CF.


  • Oh thanks for your help.  Thought that was the case but wasn't sure.  Looks like there were a few APUs we had out there that must have been running SSDs and some others that were running nano off an SD card like you said.  So that's where I got confused and because it's been so long since I worked on those I just lost track of it.  The perils of aging!!

    Thanks  ;)