• Hi i'm trying to setup a GRE Tunnel from Mikrotik to PFsense. I've a problem on PF side: if i configure the tunnel from web interface it doesn't work but if i configure it from cli it works. Those are my commands:

    Mikrotik
    /interface gre
    add !keepalive local-address=185.19.xx.xx name=tun0 remote-address=185.19.xx.xx

    /ip address
    add address=192.168.200.2/24 interface=tun0 network=192.168.200.0

    Pfsense
    ifconfig gre0 create
    ifconfig gre0 tunnel 185.19.xx.xx 185.19.xx.xx
    ifconfig gre0 192.168.200.2 192.168.200.1 netmask 255.255.255.0
    ifconfig gre0

    Thanks

  • Rebel Alliance Developer Netgate

    What version of pfSense?

    And compare the output of "ifconfig gre0" when done in the GUI vs in the shell.

    You may be hitting this, which has been fixed on 2.3: https://redmine.pfsense.org/issues/6010