OpenBGPd 0.11_4 on 2.3: Incorrect setup on package installation


  • Hi guys,

    Once installed on pfSense 2.3, OpenBGPd does not start: it looks for configuration file on

    /usr/local/etc/bgpd.conf
    

    instead of

    /var/etc/openbgpd/bgpd.conf
    

    To solve this quickly one can make a symbolic link to the expected file:

    ln -s /var/etc/openbgpd/bgpd.conf /usr/local/etc/bgpd.conf
    

    But a more elegant way would be giving the correct file location to openbgpd initialization, or better yet, updating the package scripts… I don't have the needed skills to do this. Someone can help me with?