Captive Portal não redireciona para tela de autenticação


  • Estou configurando o pfSense, ainda está fora do ambiente de produção, estou com problemas com o Captive Portal, estou autenticando por usuários, ele autentica normalmente, porém ao tentar navegar sem autenticar ele deveria redirecionar para a tela de login, mas isso não acontece, já habilitei DNS Forwarder, habilitei http, usei voucher, nada funcionou, estou utilizando a versão 2.2.6, mas tentei com a 2.3 e ficou do mesmo jeito.
    ![print 1.jpg](/public/imported_attachments/1/print 1.jpg)
    ![print 1.jpg_thumb](/public/imported_attachments/1/print 1.jpg_thumb)
    ![print 2.jpg](/public/imported_attachments/1/print 2.jpg)
    ![print 2.jpg_thumb](/public/imported_attachments/1/print 2.jpg_thumb)


  • Onde eu trabalho usamos proxy autenticado, quando o usuário abre o navegador e digita algum endereço, automaticamente abre a tele de login, em service>proxy server, na aba Auth Settings, escolha a opção de autenticação "local", depois na aba "Local Users" cadastre todos os usuários, depois va na opção service>Proxy Filter e crie o grupo de cada usuário, no meu caso uso "ouro, prata e bronze" e coloco os usuários para cada grupo. no meu caso ta funcionando perfeitamente. espero ter ajudado.


  • @antoniodjacyr:

    Onde eu trabalho usamos proxy autenticado, quando o usuário abre o navegador e digita algum endereço, automaticamente abre a tele de login, em service>proxy server, na aba Auth Settings, escolha a opção de autenticação "local", depois na aba "Local Users" cadastre todos os usuários, depois va na opção service>Proxy Filter e crie o grupo de cada usuário, no meu caso uso "ouro, prata e bronze" e coloco os usuários para cada grupo. no meu caso ta funcionando perfeitamente. espero ter ajudado.

    Estou montando com Squid Transparente e Squid Guard para montar os grupos, queria usar o Captive Portal como um hotspot para controle dos usuários, o Captive está funcionando, porém não redireciona para a tela de autenticação sem digitar o endereço dela, no meu caso 192.168.1.1:8002, ou uma dns como a 8.8.8.8, preciso que ela redirecione automaticamente se não houver nenhuma sessão aberta, não acho muito viável deixar o usuário abrir a pagina de login manualmente kkkkk, mas obrigado.


  • Consegui resolver, precisei permitir o endereço das DNS que usei no proprio Captive Portal.