Interrupt problem



  • Hi

    I am trying to install on a Compaq ML370 G2, Dual 1.2GHz with 1Gb RAM

    During the install I keep getting an "interrupt Loop error" stating that interrupts may be disabled.
    I have tried removing the 3 additional Nics that I installed, disabled all of the onboard comm ports etc and also removed the RAID card.

    Anyone manged to get pfS running on one of these machines?

    Thanks





  • Tried flashing Bios, and there are no options for ACPI within BIOS.

    Here is a more detailed shot of the error which refreshes in a loop…

    Kernel Free SCB list: 9 13 12 11 10
    Untagged Q(0): 19
    Untagged Q(1): 0
    Untagged Q(3): 1
    Untagged Q(4): 14
    Untagged Q(5): 2
    Untagged Q(6): 3
    Untagged Q(8): 15
    Untagged Q(9): 4
    Untagged Q(10): 16
    Untagged Q(11): 5
    Untagged Q(12): 6
    Untagged Q(13): 17
    Untagged Q(14): 7
    Untagged Q(15): 18

    <<<<<<<<<<< Dump Card State Ends >>>>>>>>>>>>>>>>
    (probe13:ahc0:0:14:0): SCB 0x7 - timed out
    sg[0] - Addr 0x2fe684 : Length 36
    (probe13:ahc0:0:14:0): SCB 7: Immediate reset.  Flags = 0x620
    (probe13:ahc0:0:14:0): no longer in timeout, status = 25b
    ahc0: Issued Channel A Bus Reset. 14 SCBs aborted
    Infinite interrupt loop, INTSTAT = 0ahc0: Timedout SCBs already complete. Interrupts may not be functioning.



  • Threw the server out of the window.
    Pulled out an old DELL server and worked straight away.



  • For anyone who may find this thread in the future… some of those old Compaq servers are a real pain to get any BSD or Linux distro running on. I have some Compaq servers of that same era and tried pfSense, stock BSDs, several Linux distros and none would boot regardless of BIOS settings, having all the latest firmware and BIOS revision, etc. They run Windows 2000 and 2003 no problem.

    Sometimes your best bet is to do as Gob did and find a different piece of hardware.


Log in to reply