RRD-Crash, Queue Lockups, Kernel Core Dump



  • This morning i had to replace the HDD of the gateway as it died over the weekend. The new Hdd works fine and installed without a glitch.

    Ok so i upgraded Alpha to latest snapshot for Monday July 21st and have 2 items on the list:

    1. status–-->queues ////  once clicked it will seem to load and take forever.....pause....no Webgui all of a sudden but when i check console i see that pfSense is rebooting??!!??

    2)After about 1/2 hour of loads of 20Mbit downloads and 6Mbit uploads the RRDtool crashed and stopped taking stats. The one way i was able to get it back was do this:

    From a shell do this:

    rm -rf /var/db/rrd/*

    Now click save on the Interfaces -> LAN page. I went back to rrd and loaded a graph and VOILA!!! it works.

    Kernel Core Dump:
    In the system logs file i'm seeing the following problems. (see attached image)
    Its continuous and i would appreciate any input.




  • Update:

    I removed my traffic shaping from my settings and the Kernel Core Dump have gone away. But i need the shaping so should a re0install be in place?



  • Please update to a recent snapshot i cannot see the crash dump or if you can send a back trace



  • The image that you see above contains the info about what syslog was recording. At the time of all these Kernel Core Dump messages i was configuring the traffic shaper(Monday July 21st snapshot). After i removed all traffic shaping the interface stopped popping out those errors.



  • I can't reproduce this sorry!



  • Problem is not present to this day and i have updated to Tuesday 22nd snapshot and solved all previous problems. Suspecting hardware conflict that caused this error, so i downgraded components (RAM) and will upgrade power supply and then re-add RAM and test. I will post results of this.

    First setup had 4GB RAM downgraded now to 2GB and working.



  • signal 11 repeatedly like that is typically a RAM or other hardware issue, looks like that's what it turned out to be.


Log in to reply