No local log entries since upgrade from 2.2.6 -> 2.3 (Resolved)



  • Hello,

    I upgraded form 2.2.6 -> 2.3 on April 23rd.  Before & after the upgrade I was using a remote syslog server.  Since the upgrade, pfSense shows no local log entries since April 23rd, Status -> System Logs.  Logging to the remote syslog server is working Ok.

    I've tried "Reset log files" under Status -> System Logs -> System Settings.  Now pfSense has no log entries for any services (system, firewall, DHCP, etc.)

    Did something change with local logging, if a remote syslog sever is enabled?  Is this a bug, or intended design?

    Thanks,
    Frank



  • I just discovered "Local Logging" - Disable writing log files to the local disk, and it was checked.  I un-checked it and now have local logging again.

    Re-reviewing the 2.3 New Features & Changes, I found "Fixed disabling of filter.log logging where local logging is disabled. #6018" at the bottom under Misc.  Is this related?

    I'm 100% sure I didn't change "Disable writing log files to the local disk" since the upgrade, and local logging was working before the upgrade.  If this is related to the above change, maybe the change notes should be a little more descriptive.  If the issue is not related to the above fix/change, any other ideas?

    Thanks,
    Frank



  • That config setting isn't touched by anything other than admin action. That fix was just to properly disable filter logging when that option is enabled, previously it would only disable local logging of everything but the filter log.



  • Then I have no idea what happened.

    I didn't poke around in that area at all after my upgrade, until today when I was troubleshooting a new FW rule.  There were log entries, but they all dated back to the 23rd, beforeI did my update.  I may take a look in my backup file to see what it was set at.

    Do you know what the entry is named in the backup file, so I can quickly search for it?

    Thanks,
    Frank



  • My guess if it definitely was logging before the upgrade is something about that setting wasn't immediately applied to the running system. So it would have stopped post-reboot if that's the case. I confirmed it does immediately disable on 2.3. Haven't double checked anything earlier, though I'm pretty sure that worked immediately in general.

    The config tag that enables that option is <disablelocallogging>inside <syslog>section.</syslog></disablelocallogging>


Log in to reply