Can't ping to gateway



  • Hi,
    I am using pfsense 2.3 stable 32 bit version. My public up is in 218.x.x.x/28 and gateway is in 172.x.x.x. But the problem is every time I try to assign it via pfsense it says that gateway is in wrong subnet. But web ui accepted it without any problem. But I didn't had Internet access. So I logged in to the shell and tried to ping the gateway. But it shows that no route to host. What should I do? Or is there anything I missed in the setting?


  • LAYER 8 Global Moderator

    218.x.x.x/28 and gateway is in 172.x.x.x.

    Yeah that most likely not right… A gateway should be in the same network as your IP..

    Where did you get this info?



  • You sure that's right? Your gateway is almost certainly within your /28.



  • But i can use this config with my ubuntu machine and  everything is perfect.

    Sorry but is it is necessary to be the gateway in same subnet? It's just a gateway right?





  • @rjshrjndrn:

    Sorry but is it is necessary to be the gateway in same subnet? It's just a gateway right?

    Generally your gateway is always in a directly-connected subnet, yes, that's the nature of networking. Systems generally shouldn't ARP something outside a directly-connected subnet.

    There is the "use non-local gateway" checkbox on the gateways page to use a gateway outside a directly-connected subnet if that's your situation. But that's very rarely necessary, usually if you're trying to use a gateway outside your subnet you're confused on what your gateway IP should really be.



  • System/routing/-edit/add gateway (bottom of page)

    But dont do it. Chances of it working are close to zero



  • I found that under gateway > settings > advanced options
    I enabled it and I got net access in ma pfsense machine.
    But for lan its not loading any web pages.
    I cant ping to the given gateway (via pfsense console), but can ping Google. and when I traceroute  Google, It shows * after the public ip (in the gateway portion) and then traced Google.


Log in to reply