Aggressive pinging from pfsense?



  • Is this normal?

    21:48:00.069616 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 4529, length 8
    21:48:00.094302 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 4529, length 8
    21:48:00.266360 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 599, length 8
    21:48:00.297591 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 599, length 8
    21:48:00.581381 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 4530, length 8
    21:48:00.606296 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 4530, length 8
    21:48:00.768357 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 600, length 8
    21:48:00.796311 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 600, length 8
    21:48:01.113611 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 4531, length 8
    21:48:01.137513 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 4531, length 8
    21:48:01.270361 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 601, length 8
    21:48:01.295568 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 601, length 8
    21:48:01.645612 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 4532, length 8
    21:48:01.669762 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 4532, length 8
    21:48:01.771362 IP6 2001:470:1f04:ca0::2 > 2001:470:1f04:ca0::1: ICMP6, echo request, seq 602, length 8
    21:48:01.796817 IP6 2001:470:1f04:ca0::1 > 2001:470:1f04:ca0::2: ICMP6, echo reply, seq 602, length 8

    ::2 is pfsense, and ::1 is hurricane electric.  This is traffic through the ipv6 tunnel (gif0 interface).  HE is getting pinged 4 times a second?



  • 500ms is the default setting of dpinger on 2.3, you can change it if you want (see system->routing->edit gateway)



  • Check out the time stamps of those pings – they're around 250ms apart, not 500.



  • However often it's pinging, it's still part of the gateway monitoring feature, and can be adjusted in System > Routing, and editing the gateway that you want to change the setting of.

    Note that this affects the resolution of the gateway monitoring feature. By reducing the ping frequency, you may want to increase some of the time periods used in evaluating latency and loss. You might want to read this post from the author of the dpinger gateway monitoring process. Keep in mind that the post was written while 2.3 was in beta phase, so the defaults mentioned may have been changed at the RC or release phases, but the info is still helpful.



  • If you upgraded from 2.3 beta, you may still have 250ms as the polling interval. This was the default earlier in the beta process. The current default is 500ms.

    FWIW, by default dpinger uses a data payload of 0 bytes, so the packets are much smaller than a standard ping which is a 56 byte payload.


Log in to reply