Hurricane Electric IPv6 tunnel issue



  • Today my Hurricane Electric IPv6 tunnel stopped working. In pfsense I have the following two alerts:

    pf_busy

    PF was wedged/busy and has been reset. @ 2016-05-02 12:24:02

    Filter Reload

    There were error(s) loading the rules: pfctl: DIOCXCOMMIT: Device busy - The line in question reads [0]: @ 2016-05-02 12:24:03

    I tried rebooting pfsense and disabling my (4) IPv6 firewall rules but this didn't help.

    When I try to ping an IPv6 host on the internet (like google.com) I get the following error:

    Destination net unreachable.

    I also tried disabling the Hurricane Electric interface and re-enabling but that too didn't help.

    Can someone assist please?  :)


  • LAYER 8 Global Moderator

    Well is your tunnel up??  If your tunnel is not up then no ipv6 is going to work through the tunnel..

    Did you public IP v4 change… Did you go to the HE site and check your tunnel?  I show all of them green here
    https://www.tunnelbroker.net/status.php




  • Yes the tunnel was up. Thats what I couldn't understand. Its been working for days without issue. Anyway, I worked through the pfsense IPv6 tunnel guide and I found the problem! Under the gateway settings this option was UNTICKED:

    This will select the above gateway as the default gateway.

    So I ticked it and its all working now!

    I have a public static IPv4 address so it wouldn't be this. I'm just not sure WHY this box was unticked and it stopped working. Very odd.


Log in to reply