Used Multiple Lan/Wan Wizard, HFSC, Plex Disconnects Playing Locally



  • When I enable traffic shaper with Multiple Lan/Wan Wizard, and HFSC, plex will bomb out playing a video about ~5 minutes in. The video will abruptly stop playing. Almost like the traffic shaper is dropping an important connection. I'm playing the plex video locally @ 192.168.1.0/24 , but I think plex talks back to home base every now and then too. I would think the traffic shaper would leave the LAN alone. Pex traffic (when accessed locally) between my client and my server should be mostly through my switch network and not the router, I would think



  • You should find out how you're connecting to your Plex server, if it's through the router, LAN, or both. I am not familiar with Plex, but I assume you had to configure the server location for the clients or the clients are auto-discovering via the local subnet.



  • It's a web interface http://192.168.1.52:32400/web/index.html

    it does talk back to the main plex servers in the 'cloud' for some things. like verification of my license key. probably some other stuff

    I'm playing the video through chrome… then all of the sudden plex tells me something was wrong playing the video. If I turn off traffic shaper, i dont have the issue



  • Like you said, LAN-to-LAN data is not routed through pfSense.

    Heck, to be sure that pfSense is not to blame, start a Plex video then disconnect the ethernet cable that goes from your switch to your pfSense router. The stream should continue, but now pfSense is completely out of the loop.



  • Try your Google-fu:

    https://forums.plex.tv/discussion/142929/plex-without-internet-access

    it is dependent on internet for authentication. so you need to disable it while your internet is down.  you should just need to disable Require auth on local networks



  • @moikerz:

    Try your Google-fu:

    https://forums.plex.tv/discussion/142929/plex-without-internet-access

    it is dependent on internet for authentication. so you need to disable it while your internet is down.  you should just need to disable Require auth on local networks

    His streaming video fails after 5 minutes of playing, not during the authentication stage.



  • Is there anything in the traffic shaper configuration to say "ignore this local ip" completely ?



  • @meruem:

    Is there anything in the traffic shaper configuration to say "ignore this local ip" completely ?

    Traffic is assigned to a particular queue by firewall rules. All unassigned traffic uses the "default queue".

    If you are using CODELQ (I think it is just a single " default" queue), I dunno if you can avoid the queue.

    The bigger problem is that Plex does not halt playback mid-stream for an unavailable, external resource. Additionally, pfSense should not even be encountering the LAN-to-LAN traffic… your switch should be handling that traffic.

    If you could share more details about your LAN toplogy and your pfSense setup, it would help.


Log in to reply