[Help]DNS Resolver can not be modified or changed



  • This is in line with my post <https://forum.pfsense.org/index.php?topic=111188.0>.
    I would like to add few details.

    1. General DNS Resolver Options cannot be modified or changed to any configuration. (System Domain Level Zone Type: Redirect)
    2. It shows these errors when saved:

    [1462256303] unbound-checkconf[38210:0] error: local-data in redirect zone must reside at top of zone, not at firewall.umbansalan.lan A 192.168.16.1
    [1462256303] unbound-checkconf[38210:0] fatal error: failed local-zone, local-data configuration
    

    I have tried editing the /var/unbound/unbound.conf and /var/unbound/host_entries.conf but to no avail, it will not post changes to the services_unbound.php.

    Looking forward to fix this problem.


  • LAYER 8 Global Moderator

    How about some details dude.. What do you have in the custom options?  What are your other settings?

    Why would you try and edit conf directly?



  • Here's the current setting sir

    • DNS Resolver is ENABLED

    • Listen Port: 53

    • Network and Outgoing Interfaces: All

    • System Domain Level Zone Type: Redirect

    • DNSSEC: Unchecked

    • DNS Query Forwarding:Checked

    • DHCP Registration: Unchecked

    • Static DHCP: Unchecked

    I would like to set it to default(System Domain Level Zone Type: Transparent) but errors occur.

    With the conf editing sir, it's just an attempt to solve the problem - just trying some possible sort.
    But when the SAVE button is pressed (in the /services_unbound.php) confs are back to original.


  • LAYER 8 Global Moderator

    You seem to have run into some sort of issue… I tried changing mine to redirect, and then back and now getting errors as well..

    Give me a bit..

    Ok this is how I got mine back to working... I download the backup for the resolver.. Then edited the xml file, on the bottom you should see section

    
    <system_domain_local_zone_type>redirected</system_domain_local_zone_type>
    
    

    Change it to

    
    <system_domain_local_zone_type>transparent</system_domain_local_zone_type>
    
    

    Then restore resolver section..

    This got me back to running..  This sure seems like a bug in how something is parsed or the config file is being generated.

    When I get some time will document and post a bug report..



  • Thanks sir,

    However, I found it hard where to download the backup of the resolver and when I edited the config.xml file in the /conf folder it will revert back to its previous state when save button is press in the /services_resolver.php page…


  • LAYER 8 Global Moderator

    you download the backup in the diagnostics, backup & restore section.

    Another option for you to revert your change.. when did you change the resolver settings from default?  In the same section you can look at your config history and find where you changed it and revert to that config.  But if it was some time ago with lots of other changes since than that might not be a good idea..

    The simple edit was how I got unbound back to transparent after changing to redirect.




  • Thank you sir johnpoz,

    Mine's been working already as of yesterday.



  • Thx for the solution Johnpoz, this issue is still present in the 2.4beta 28th Feb 2017.



  • This is still an issue with a relatively fresh 2.3.4-Release install, as well.  Be careful switching your DNS Resolver "System Domain Local Zone Type" setting to "Redirect" as you may not be able to change it back!


  • LAYER 8 Global Moderator

    hmmm I have not gotten back to this - and do not recall if I ever filed any sort of bug report.  I am currently running 2.4 beta - I will try and reproduce again in 2.4 and if clean there will fire up a copy of 2.3.4 and try it there.


Log in to reply