A valid hostname is specified, but the domain name part should be omitted



  • Hi All,

    When i try to assign any static ip with DHCP server, i am getting this error message:

    "A valid hostname is specified, but the domain name part should be omitted".

    Earlier i was able to do this, from last update,it is giving error. Please help me.

    ![DHCP Error.PNG](/public/imported_attachments/1/DHCP Error.PNG)
    ![DHCP Error.PNG_thumb](/public/imported_attachments/1/DHCP Error.PNG_thumb)


  • LAYER 8 Global Moderator

    what exactly are you putting in?

    It says right under the hostname part in static mapping not to include the domain name

    "Name of the host, without domain part."

    You can put in an alternate domain name farther down in the form






  • I am just giving only host name there, not including Domain name, it is not taking any thing there.
    Even if i give a simple name also,it is not accepting and getting the same error.

    ![static error.PNG](/public/imported_attachments/1/static error.PNG)
    ![static error.PNG_thumb](/public/imported_attachments/1/static error.PNG_thumb)



  • Edit: nevermind, looked at that way too quickly. It's correct as-is.



  • I tried giving all lower cases also, but still getting the same error. Please check the screen shot once.

    ![error dhcp.PNG](/public/imported_attachments/1/error dhcp.PNG)
    ![error dhcp.PNG_thumb](/public/imported_attachments/1/error dhcp.PNG_thumb)



  • Actually I looked at that way too quickly, it was correct as-is, it's not caps-sensitive.

    What version is that? Going back to 2.1.x code, it checks whether it contains a . and gives that message if it does. In 2.2.x and newer, just that it contains only valid characters for a hostname without domain. That content passes the check in both cases.



  • This is 2.2.2 Release.




  • The check in 2.2.2 matches that as well. Make sure there aren't spaces or any other characters than the text there.



  • I have checked it, earlier i was able to create them. Is there any configuration files i need to check ?
    Few other posts are stating that we need to edit "services_dhcp_edit.php" in /usr/loca/www.


  • LAYER 8 Global Moderator

    I never understand why people do not update..  2.2.2 is over a year old.. There were 4 more releases in the 2.2.x line to fix security, bugs and add features.  Why are you not atleast not on 2.2.6?

    Pretty much anytime you call for support to any major player cisco, juniper, microsoft, etc etc..  Are you on the latest version/patches.. And really do not like supporting you until your current.

    You sure there is no space on the end of the name?



  • @sashikanth:

    Few other posts are stating that we need to edit "services_dhcp_edit.php" in /usr/loca/www.

    From people who had . in the hostname, from several years ago before there was a domain field and they wanted sub-domains. There is no need to edit anything.



  • Hi Johnpz,

    We have updated to the latest version, it is observed that after updating only we are getting this issue, So that we reinstalled the older version manually. Still getting the same issue with the older version also now.

    We are sure there are no spaces in the hostname, checked many times.


Log in to reply